Deactivate warnings

Hello,

I tried to remove the logs of the warnings using the carbs settings specified in this issue How to stop printing warning level messages to console for Isaac sim? - #3 by Hammad_M However, the warning are still printed. Here is my code, what do I do wrong?

from omni.isaac.kit import SimulationApp
headless = False
simulation_app = SimulationApp({"headless": headless})  # we can also run as headless.
import logging
import carb

logging.getLogger("omni.hydra").setLevel(logging.ERROR)
logging.getLogger("omni.isaac.urdf").setLevel(logging.ERROR)
logging.getLogger("omni.physx.plugin").setLevel(logging.ERROR)

l = carb.logging.LEVEL_ERROR
carb.settings.get_settings().set("/log/level", l)
carb.settings.get_settings().set("/log/fileLogLevel", l)
carb.settings.get_settings().set("/log/outputStreamLevel", l)

# This logged error is printed as it should
carb.log_error("ERROR")
# This warning is printed but should not
carb.log_warn("WARNING")
1 Like

@alempereur did you get it to work. I can’t get it to work either.

No I still have the problem