Deepstream nvtracker metadata frequency

Hi everyone,

I’m using Deepstream 5.1 on an Xavier NX with Jetpack 4.5.1.

I am running the deepstream_test_2.py app with past frame meta support enabled by following the README instructions. I have noticed that on this section of code

                for trackobj in pyds.NvDsPastFrameObjBatch.list(pPastFrameObjBatch):
                    print("streamId=",trackobj.streamID)
                    print("surfaceStreamID=",trackobj.surfaceStreamID)
                    for pastframeobj in pyds.NvDsPastFrameObjStream.list(trackobj):
                        print("numobj=",pastframeobj.numObj)
                        print("uniqueId=",pastframeobj.uniqueId)
                        print("classId=",pastframeobj.classId)
                        print("objLabel=",pastframeobj.objLabel)
                        for objlist in pyds.NvDsPastFrameObjList.list(pastframeobj):
                            print('frameNum:', objlist.frameNum)
                            print('tBbox.left:', objlist.tBbox.left)
                            print('tBbox.width:', objlist.tBbox.width)
                            print('tBbox.top:', objlist.tBbox.top)
                            print('tBbox.right:', objlist.tBbox.height)
                            print('confidence:', objlist.confidence)
                            print('age:', objlist.age)

The “streamId=” and “surfaceStreamID=” prints are shown on every frame but not the ones on pastframeobj loop, even when an object is being detected and the bounding box is visible. As far as I understand this is because the nvtracker is not reporting the tracker metadata downstream due to some confidence settings or something like that. For my use case I would like to know the bounding box data at every frame that the tracking is alive (whether it is on active or inactive state see diagram).

I noticed that by setting useBufferedOutput to 1 in the tracker_config.yml I get the bbox data printed on more frames but not on all of them where there is the object detected. Is there any specific configuration in the tracker config file that allows me to achieve this?

Thanks in advance!

Sorry fo the late response, is this still an issue to support?

Thanks

Hi @kayccc,

Yes, it is still an issue.

Can you have a try with maxShadowTrackingAge=0 and earlyTerminationAge=0? This setting will disable shadow tracking and output bbox data immediately.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.