Deepstream pipeline low frame rate when rtsp stream is used

• Hardware Platform (Jetson / GPU) Jetson Nano
• DeepStream Version 6.0
• JetPack Version (valid for Jetson only) 4.6
• TensorRT Version 8.0.1.6

I’m using DeepStream with Python bindings. I have constructed a simple pileline that consists of the following elements:

uridecodebin → nvstreammux → nvinfer → nvtracker → nvvideoconvert → fakesink

The pipeline works at about 32fps when a file is used as a source. However when I try to use an rtsp camera frame rate is about 20 for the first 1000 frames and then drops to 3.

nvstreammux is created using the following properties:

        streammux.set_property('width', 1920)
        streammux.set_property('height', 1080)
        streammux.set_property('batch-size', 1)
        streammux.set_property('batched-push-timeout', 4000000)

        if self.video_uri.find("rtsp://") == 0 :
            streammux.set_property('live-source', 1)   

Is this expected behaviour? I’m a beginner with DeepStream pipeline and trying to use it for production as nothing else seems to work a device as small as a Nano.

No.

But we need more information to analysis what happened to the pipeline. Have you enabled “GST_DEBUG=3” log?

I tried

export GST_DEBUG=3

and then executed my app again. How can I inspect the logs now?


This is a screenshot from jtop output while my app is running. GPU clocks are at 76MHz. Is this normal?

Please note that after a few minutes GPU utilization drops to 0% and the app hangs.

There should be log print in your terminal.

These are the messages I receive after setting GST_DEBUG=3:

FIXME default gstutils.c:3981:gst_pad_create_stream_id_internal:fakesrc0:src Creating random stream-id, consider implementing a deterministic way of creating a stream-id
Opening in BLOCKING MODE
0:00:04.928043540 17264 0x7ef40030f0
WARN v4l2 gstv4l2object.c:4476:gst_v4l2_object_probe_caps:nvv4l2decoder0:src Failed to probe pixel aspect ratio with VIDIOC_CROPCAP: Unknown error -1

This is the whole log?

Yes. Have you checked the other post I made with the jtop screenshot? The GPU frequency drops below 100MHz. Is this expected behaviour?

It depends on what happened in the pipeline. Currently there is no clue.

The cause was thermal throttling. The nano was being overheated. Problem was solved when a fan was placed on top of the heatsink.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.