deviceQuery.exe cannot be located after install

Tried to install GPU driver (Geforce630) and CUDA 7 on win7(64) without error.

deviceQuery.exe cannot be located after install either in specified folder or by disk search.

Does it need further compile, any reference, thanks.

You have to install CUDA, not just the GPU driver, to get deviceQuery.exe

And yes, you may have to build the deviceQuery sample code in Visual Studio.

The windows getting started document should help:

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-microsoft-windows/index.html#abstract

CUDA 7 already installed.

In C:\ProgramData\NVIDIA Corporation\CUDA Samples\v7.0\bin\win64\Release

Only
freeglut.dll
FreeImage64.dll
glew64.dll

Yes, you need to build the samples first.

http://docs.nvidia.com/cuda/cuda-samples/index.html#abstract

“The CUDA Samples are no longer shipped as prebuilt binaries on Windows. Please use VS Solution files provided to build respective executable.”

Please follow the directions in the getting started guide:

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-microsoft-windows/index.html#abstract

in the link you mentioned also, It is said to run that exe.file which I cant find previously

“The CUDA Samples are no longer shipped as prebuilt binaries on Windows. Please use VS Solution files provided to build respective executable.”

txbob is right. You have to compile them yourself in Visual Studio with CUDA 7, although the manual still states they should be there. Ran into this myself this week.
Think they need to update the documentation, because it says: “CUDA Samples include sample programs in both source and compiled form.”

Hi,

I build deviceQuery.exe using Visual Studio, however when I ran it, the command window just opens and closes very quickly. Does it mean I did not install CUDA properly?

Don’t run it from within Visual Studio. Run it from the command line. Then you will be able to see whatever is being reported.

Don’t run it from within Visual Studio. Run it from the command line. Then you will be able to see whatever is being reported.

What is the exact command to run it from the command line? None of the links above work in providing this information.

find the directory where deviceQuery.exe is located (after you built it). If you’re unsure how to do this, use the windows find utility, from the file manager.

Once you’ve located the directory where it is located (let’s say it is xxxyyy), open up a command prompt.

From within the command prompt, type:

cd xxxyyy

(except instead of xxxyyy, you are typing the actual directly where deviceQuery.exe is located)

then type:

deviceQuery

I have the same problem as Alex above:

CUDA 7 already installed. (<-- but for me, CUDA 8)

In C:\ProgramData\NVIDIA Corporation\CUDA Samples\v8.0\bin\win64\Release

Only
freeglut.dll
FreeImage64.dll
glew64.dll

deviceQuery.exe does not exist in the directory that it should be in, so I run it. There are comments above about how to build deviceQuery.exe, but it isn’t clear how to build it. It was stated not to use VS, but run it command line, I have no idea what to run because the .exe doesn’t exist. Am I supposed to build deviceQuery.exe? If so, how? It isn’t installed when I install the program.

Ok, I think I resolved it. BTW, I am an NVIDIA employee and I’m very motivated to get this running, but it has taken me a lot of time to resolve this. Even though to most CUDA developers these are trivial, I was very close to just giving up many times. I suggest a few more updates to the getting started directions:

  1. Install Microsoft Visual Studios 2015 or before. The default on the Microsoft website as well as the pointer that is given to us during CUDA installation points us to 2017. VS 2017 simply won’t work and will cause headaches, and VS 2015 takes some determination and digging to download and install.

  2. deviceQuery.exe doesn’t exist, it needs to be compiled. Users need to start up Visual Studio 2015, open the corresponding Microsoft Visual Studio Solution File (e.g., “Samples_vs2015.sln”) and then “Build Solution”.

  3. The file will not be in the “Release” directory as mentioned in the CUDA directions, it is in the “Debug” directory.

2 Likes

I have windows 10 64 bit and version 8 CUDA, and I also cannot run the deviceQuery.exe command. I have a GeForce GTX 1050. Any advice?

Like the above posters have mentioned, you need to install a compatible version of Visual Studio and then open the Visual Studio project file that you want to compile. Make sure you compile in Release mode rather than in Debug mode unless you actually want to step through the code to figure out what it does. Once it’s compiled, you will be able to run it via the command line.

Hi, I have compiled the code and have device query but it fails when I run the executable. When i went into debug mode in Visual studio the message that pops up is the following:

"
Unhandled exception at 0x00007FF9954AA0E0 (nvcuda.dll) in deviceQuery.exe: 0xC0000005: Access violation reading location 0x0000000000000010.

If there is a handler for this exception, the program may be safely continued.
"

Any ideas?

Hi All,

I am a newbie, this thread helped me address the “deviceQuery.exe” not found.
Nvidia ToolKit installation only copies the cuda sample files to the installation directory.
The corresponding “.exe” files can be generated by building/compiling the sample files.

I used windows 10 64 bit and version 9.1 CUDA Toolkit. Was able to generate deviceQuery.exe and bandwidthTest.exe using MS VS2017 15.4.

The “.exe” files were created at “C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.1\bin\win64\Debug”

Hope this helps!

The exe files where missing even though the instructions explcitly state that they are included: http://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/

working through this same situation.
blog with screenshots and steps.

it’s a WIP right now, will update.

bunch of blogs also on my medium account for deep learning using CUDA, with Pytorch, KERAS, tensorflow etc.

I found this link is useful: https://www.olegtarasov.me/how-to-build-cuda-toolkit-projects-in-visual-studio-2017

So basically if you unselect VS integration, you need to do something by hand

1 Like