Docker DeepStream-6.1.1:App run failed

Jetson AGX Orin
Jetpack 5.0.2 GA
My operational steps:

  1. Flashing the JetPack 5.0.2 GA version
  2. Install jetpack SDK

sudo apt-get update
sudo apt-get install nvidia-jetpack

  1. Pulling and successfully running a sample using Docker DeepStream 6.2

sudo docker pull
sudo docker run -it --rm --runtime nvidia --gpus all bash
cd /opt/nvidia/deepstream/deepstream-6.2/samples/configs/deepstream-app
deepstream-app -c source2_1080p_dec_infer-resnet_demux_int8.txt

  1. However, I pulled DeepStream 6.1.1 and attempted to run a sample, it failed.

sudo docker pull
sudo docker run -it --rm --runtime nvidia --gpus all bash
cd /opt/nvidia/deepstream/deepstream-6.1/samples/configs/deepstream-app
deepstream-app -c source2_1080p_dec_infer-resnet_demux_int8.txt

sudo apt-cache show nvidia-jetpack | grep "Version"

Can you get the jetpack version using the following command? Because on Jetson, some shared libraries are shared between the host and Docker.

Therefore, it is recommended that docker uses the same version of deepstream as the host.

Here is the compatibility table

1 Like

Yes, I have confirmed that my Jetpack version is 5.0.2GA. I cross-referenced the compatibility chart, so I believed that I should have been able to successfully run samples from DeepStream 6.1.1. However, in reality, I managed to run samples from DeepStream 6.2 without any issues, whereas the samples from version 6.1.1 failed to run.

Furthermore, I conducted an experiment where I was able to successfully run DeepStream 6.1.1 on my local machine, but it failed to run on Docker. Despite this, I am confident that my operation for pulling the Docker image was not problematic.

nvidia@nvidia-desktop:~$ sudo apt-cache show nvidia-jetpack | grep “Version”
[sudo] password for nvidia:
Version: 5.0.2-b231

sudo docker run -it --rm --runtime nvidia bash

Try starting docker with the following command. On jetson, --gpus all is unnecessary.

I listened to your advice, but still encountered the same failure.

There is another phenomenon where, after following identical operation steps on the 3 Jetson AGX Orin modules I have at hand, one of them successfully runs the sample program while the other two fail to run the same sample. Could this situation be indicative of a hardware issue?

These problems are usually caused by incorrect installation of jetpack & deepstream.

Try clearing gstreamer’s cache using the following command.

sudo /opt/nvidia/deepstream/deepstream/ 

First ensure that you can see the log output from the gst-inspect-1.0 nvstreammux.

In addition, since your jetpack version is 5.0.2, it is recommended that you use DS-6.1.1.
By the way, are the Jetpack versions of your three devices the same?

For docker, try the following command to install nvidia-container-toolkit

 "sudo apt update"

 "sudo apt install"

 "sudo apt install nvidia-container"

 "sudo apt install nvidia-l4t-gstreamer"

 "sudo apt install nvidia-l4t-dla-compiler"

 "sudo service docker restart"

Three AGX ORIN devices are all running Jetpack version 5.0.2,
and on each of them, the same Docker command was executed to pull the NVIDIA DeepStream 6.1.1 L4T image:

sudo docker pull

Is the above installation command executable even if it has been installed previously?
The result from a recent execution shows:

0 upgraded, 0 newly installed, 0 to remove and 436 not upgraded.

However, when attempting to install the nvidia-l4t-dla-compiler package:

E: Unable to locate package nvidia-l4t-dla-compiler

Okay, no problem, I tried it

DS-6.1.1 may not require this, you can ignore the error for now.

But it seems like there hasn’t been much change

Still failing to run

If you start the docker shell first and then run deepstream-app, will it work properly?

If that doesn’t work, run the following command first, and then run deepstream-app

export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/

Sorry, did you mean that I ran the following commands in order?

sudo Docker run it -- rm -- runtime nvidia 6.1.1 Triton bash

cd/opt/nvidia/deepstream/deepstream 6.1/samples/configs/deepstream app

deepstream app - c source2-080p-dec-infer resnet_demux-int8.txt

If the operation fails:

Export LD-PRELOAD=/usr/lib/arch64 Linux gnu/libgomp. so. 1

Deepstream app - c source2-080p-dec-infer resnet_demux-int8.txt

Is that so?

But it still doesn’t work

Additionally, I am running on the same device:

sudo Docker pull

sudo Docker run it rm runtime nvidia gpus all 6.2-triton bash

cd /opt/nvidia/deepstream/deepstream 6.2/samples/configs/deepstream app

deepstream app - c source2-080p-dec-infer resnet_demux-int8.txt

The result is App run successful!

Does this have any reference value?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

I think DS-6.1.1 should run correctly with Jetpack 5.0.2.

Can you use sdkmanager to re-burn the software stack (no only bsp).

Very strange, is your board provided by a third party or Nvidia?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.