.dts audio streaming issue in PCI rootcomplex

We have configured the Jetson AGX Xavier boards as PCI endpoint and root complex and tried to transfer audio data from PCI endpoint to root complex using endpoint dma channels.

When we tried to transfer and stream .wav audio, it got transferred and streamed properly on the root complex side. But, when we try to transfer .dts audio it is not getting streamed properly. Instead of proper audio of .dts data, it is streaming noise.

We are using gstreamer application to stream audio data from audio node on root complex.

The gstreamer command that I used to stream both .wav and .dts audio data on root complex from audio node is given below:

gst-launch-1.0 alsasrc device=hw:, ! decodebin ! audioconvert ! alsasink device=hw:, sync=false

Suggest any way to properly stream .dts data from audio node on root complex?

We don’t actually have experience about this audio format. Would need other users to share experience. Probably would need to install additioanl audio decoder.

Not sure but this probably helps: dtsdec

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.