Dual head setup

I cannot figure out how to set up two displays located above/below. I did read the documentation in /usr/share/doc/nvidia/*. Before I used Intel graphics with xinerama and this string

xrandr --output HDMI2 --primary --below DP1

in ~/.xinitrc did the job.
My card is GeForce GTX 1660, driver 435.21. Now I can get it working in left/right configuration, but when I try above/below it kind of stretches one screen to two displays, the result is unusable.
It has been long time since I had any nVidia hardware, is Twinview gone now? There is no Twinview option when I fire up nvidia-settings.
I’ve spent 2 hours now on this puzzle, is there at least some working example for xorg.conf or any documentation in more detail?

This rather sounds like you’re using a DE like gnome or kde which have their own monitor manager which is interfering. Don’t use the xrandr command but the monitor manager of the DE to arrange them.

Thanks for reply. I use plain OpenBox, the whole setup has no GUI setup utilities whatsoever, well, nvidia-settings is now installed and it has a GUI. But other than that everything is manual, running Gentoo, BTW.
When I try with xinerama enabled then xrandr does not work any more. So the very first question is, shall I turn it on or off? I want applications to be aware there are two screens and I want to be able to drag from one screen to another, can it be done without xinerama?

Twinview/Xinerama was only necessary before randr 1.2 (2007). Please turn it off.

Thanks. So far I’ve learned this GUI tool nvidia-settings is good for nothing. Just confirming my opinion of GUI tools. Will try and set it up by hand.
How can I override EDID with nvidia driver? I tried to add a custom mode with xrandr and it failed.

It’s unlikely that a dfp monitor will support a mode that’s not in the edid. To override, you can either load a custom edid or use AllowNonEDIDModes overrides:

Thanks again. The issue is EDID is not read, possibly because of DP to DVI adapter. I have a modeline for it I want to use.

Frustration is growing. I’m starting to think my desired configuration is not achievable with nVidia. It was so simple with Intel (xrandr command in my initial post) without xorg.conf. Now I’ve spent hours editing xorg.conf and messing with xrandr, nothing works. I get a weird split screen on my main monitor and that’s it. I think I just threw away a few hundred dollars. :(

Can you possibly extract the proper EDID without the adapter? If so, then feeding that back to the driver with the CustomEDID option is probably the easiest approach.

Given the problem you seem to be having with the monitor, I’m a little surprised that the xrandr command in your first post was all you needed. Did EDID reading work with Intel and stop working when you switched to NVIDIA?

Please enable the option ModeDebug (documented here), restart the X server, and then run “sudo nvidia-bug-report.sh” and attach the resulting nvidia-bug-report.log.gz file here.

Thank you, will do. With Intel I used VGA output and EDID was read. Right now I’m discovering CUDA and NVEnc, the quality of H.265 encoding is better than I expected. :)

OK, after loading EDID from a file I finally got somewhere. That is, I figured out why I’m getting that split screen. There is one final (?) issue though.

For some odd reason the second monitor is “disabled” when X starts. It displays console no problem, but when X starts then in Xorg log it shows up disconnected. I can run ‘xrandr --auto’ or click “Detect Displays” from GUI utility and it starts working. Is this a known issue? Is there a remedy?