Dual Monitor issue with K1

We have an issue when using 2 screens in full screen mode randomly when you log in it freezes and you get vertical and horizontal scrolls bars on your endpoint device. The Xendesktop session never launches the only solution is to kill it from the Delivery control and have the user login again. This only affects multi-monitor users, single screen users work just fine. I have tried setting the resolution to the lowest on the monitors as a test and still have the same issue. Environment information below.

Dell R730 Server
2 K1 cards installed in server
Hypervisor: Vsphere 6.0 All updates as of 1/6/2016
Citrix Xendesktop 7.6 with most current VDA
Citrix PVS 7.6
Driver version from Nvidia: 354.56

Virtual machines
4GB Memory
Profile 120Q (Have tried with all the other profiles as well, same issue

If I uninstall the Nvidia driver from the VM the issue goes away even if I leave the card attached to the virtual machine. Reinstalling the driver the issue comes back

Any thoughts?

First observation is you have too few vCPU for a GPU accelerated session.

Are you using XenApp? Since you have 2008R2, there’s no HDX3dPro support which has the tightest integration with vGPU.

Which driver do you have in the guest VM?

We are using Xendesktop and doing server VDI, it is not xenapp. I realize there is no HDX3dPro support with 2008R2, however there is a noticeable improvement when using the VGPU.

The guest VM has Nvidia version 354.56

I can try increasing the vcpu count as a test, however the vcpu’s are not stressed in our testing.

What version of vGPU manager is installed in the ESX host?

The version that comes in the 354.56 driver download. The version match. and the VGPU works correctly for people with single displays. It is the users that have 2 displays that have issues.

I just got done testing with 4 vcpu’s as well and I still have the same issue.

Did the K1 cards come shipped with the server, or did you retrofit them yourself?

Can you check the firmware of the K1 cards.

Have you got a call logged with Citrix so they can analyse the protocol errors and identify where it’s failing?

I’ve a list of links to common CTX articles that affect graphics https://virtuallyvisual.wordpress.com/useful-links/useful-ctx-articles/

Could you check

  1. CTX201804 – Intermittent Connection Failures/Black Screen Issues when Connecting from Multi-monitor Client Machines to Windows 7 VDA with VDA 7.x on vSphere/ESXi
  2. if using standard VDA that the RAM is sufficient with multi-monitors: see verify memory section in CTX201696 – Citrix XenDesktop and XenApp – Support for Monitors Including 4K Resolution and Multi-monitors
    Also beware with multi-monitors they all need to be set to same dpi CTX202319 – Multiple Monitors – Mouse Cursor Jumping Around, Out-of-sync if DPIs of Monitors Are Not Matched

There are hyperlinks on the webpage… Do let me know if anything helps (or if it doesn’t)
Best wishes,

Where did the K1’s come from and how old are they?

If you acquired them before Nov 2013 and have transferred them into a new chassis, they may need the multi monitor firmware


If they are recently purchased with the server chassis, this shouldn’t be necessary, as all cards shipped after Nov 2013 already have this firmware.

These cards came with the servers in October of 2015 so they should have the latest firmware. Monitors are set to the same resolution and DPI. We have a case open with Citrix and are getting nowhere with them.

Can you check that any power managment is turned off.

Change the Windows 7 VM power plan to High Performance disabling the ‘turn off display, sleep timeout, turn off hard disk’ settings.

Sorry for the late reply I need to turn on e-mail notifications. Power management is all turned off and high performance plan is selected.

i have the exact same Problem since at least a year. there is no solution i’m afraid. Citrix blames Microsoft and vice versa. nobody wants to be responsible. Long Story short: vsphere, k1 grid and xendesktop on Windows 7 is a no-go with multi-Monitor. sad but true