Enabling hardware acceleration for a Dockerized Electron app


I’m trying to enable GPU video decoding for an Electron app running inside a Docker container. I’m using this nvcr.io/nvidia/l4t-base:r35.1.0 base image for my Docker container.

I’ve tried adding the following flags when running the Electron app: --enable-unsafe-webgpu --enable-features=Vulkan --use-vulkan=swiftshader --use-webgpu-adapter=swiftshader

My Docker container is running with runtime: nvidia.

In my logs I’m seeing Can't read /proc/cpuinfo: Permission denied which I’m not sure is related, and videos are playing without hardware acceleration.

I’ve tried looking all over the place, but haven’t found anything which worked… If anyone has any idea how to go about fixing the problem, I’d be super grateful!



Is the cpuinfo node essential for your application?
For example, failure to read the node will trigger some fallback path without using GPU.

If yes, you can try to mount the node to see if can read it.


Hi @AastaLLL,

Apologies for the tardy response!

I managed to mount the node (and had to provide extra privileges to read it), which got rid of the error, but still it seems like hardware decoding isn’t available (see attached screenshot).

If you’ve got any other ideas how I might get it working, I’d be incredibly grateful!




This sounds more related to the building configuration in the library.

For example, in OpenCV, we can enable GStreamer support with -D WITH_GSTREAMER=ON.
Please check if there is a similar flag in your use case.