Error: couldn’t switch to requested monitor resolution

Hello, I have a problem launching games through Steam and Heroic Launcher.
20240430_113555
If you run the game directly from the folder and close it, then all games start normally until the next reboot. Apparently this problem only occurs in steam flatpak, since RPM does not have this problem.

  • GPU: NVIDIA GeForce RTX 3060 Laptop GPU
  • Driver: 550.76
  • OS: Fedora 40 KDE (Wayland)

Perhaps this will be useful:

In version 550.78 everything is unchanged…

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I’m sorry, I’ve attached it here
nvidia-bug-report.log.gz (396.8 KB)
As it turns out, this problem also occurs in Bottles.

Reading the github issue and the logfiles, I guess you should manually add the nvidia modules nvidia,nvidia-drm,nvidia-modeset to the initrd:
https://www.suse.com/de-de/support/kb/doc/?id=000019945

The instructions did not work because they are not suitable for Fedora. I added modules to the grub and modprobe load, but this did not bring any results, the error remains.

I’m not a fedora user, but that’s what search engines are for:

For Fedora, just put the module name in /etc/modprobe.conf and run mkinitrd. See also Common kernel problems - Fedora Project Wiki.

Thank you for your “invaluable” help, only this is outdated documentation, and the current one is here: Working with Kernel Modules :: Fedora Docs. I did everything according to it, there was no effect.

UPD:
Still, I managed to add modules to the initrd, so I’ll follow the guide: Работа в системе — Неофициальный FAQ по Fedora (версия 2023.05.30)
But alas, the error remains…
nvidia-bug-report.log.gz (401.4 KB)

Please disable the simpledrm driver and check if that helps.

I specified nvidia-drm.modeset=1 in grub, the problem remained.

Please check flatpak for installed nvidia support:
flatpak list |grep nvidia