error: #error -- unsupported GNU version! gcc versions later than 4.9 are not supported!

Hi, guys:

I’ve already upgraded my OS to Ubuntu 16.04 - beta 2, which defaultly comes with gcc-5.3.1 and g+±5.3.1 …
However, when I build cuda 7.5 and opencv-git, I got the error as the subject.
error: #error – unsupported GNU version! gcc versions later than 4.9 are not supported!
Is there a workaround ???

Cheers
Pei