error: impossible constraint in ‘asm’

Hi All,
I’m trying to compile ROOT (http://root.cern.ch/drupal/) on the jetson TK1 but am running into errors:

/home/ubuntu/ROOT/root/math/vc/src/cpuid.cpp:129:13: error: impossible constraint in ‘asm’
CPUID(0);
^
/home/ubuntu/ROOT/root/math/vc/src/cpuid.cpp:132:13: error: impossible constraint in ‘asm’
CPUID(1);
^
/home/ubuntu/ROOT/root/math/vc/src/cpuid.cpp:161:22: error: impossible constraint in ‘asm’
CPUID(0x80000001);
^
/home/ubuntu/ROOT/root/math/vc/src/cpuid.cpp:168:26: error: impossible constraint in ‘asm’
CPUID(0x80000005);
^
/home/ubuntu/ROOT/root/math/vc/src/cpuid.cpp:175:26: error: impossible constraint in ‘asm’
CPUID(0x80000006);
^
/home/ubuntu/ROOT/root/math/vc/src/cpuid.cpp:189:17: error: impossible constraint in ‘asm’
CPUID(2);
^
/home/ubuntu/ROOT/root/math/vc/src/cpuid.cpp:225:26: error: impossible constraint in ‘asm’
CPUID_C(4, i);

I’ve compiled ROOT many times on many different linux ARM boards (even fedora21 for this specific board) and haven’t run into these errors before. This could be a bug in the Assembly routines coded into Nvidia’s Ubuntu?

Thanks!

I was able to compile ROOT straight from the git sources without any issues, what version of L4T are you running?

I’ve just installed R21.2.0 and I’m still having the same issue. I also used the git source which is now Root 6.03.

Any ideas?

Mine was a clean install of 21.2 via JetPack, maybe you should try the same if you haven’t already?

Hi there, still no luck. I did a re-install of 21.2 with JetPack and used the root git source.

Do you know where I go from here/who to contact?

Thanks for the help!

Just to follow up, I finally got ROOT compiled. It seems theres an issue with the VC libraries (solved by adding --disable-vc) as well as the GSL and mathmore libraries (solved by adding --disable-mathmore). I had all the optionals installed which ROOT found and then failed on.
However, there seems to still be a lot of bugs with tegra ubuntu kernel/OS. I finally gave up trying to run an analysis in ROOT.

Hello jsmith,

If possible, could you elaborate on the bugs that you’ve found with the kernel or the OS, and provide logs if applicable? We’d like to investigate the issues and see if we can possibly resolve them.

Thanks,

-Chris

Hi Chris,
I can’t supply the logs unfortunately, i’ve re-flashed and put fedora21 on the jetson. But it should be fairly easy to reproduce.
ROOT failures are triggered using the optional dependencies shown here https://root.cern.ch/drupal/content/build-prerequisites for ubuntu. Specifically, gsl and vc libraries gave me errors. I couldn’t tell you what the specific bugs in the jetson kernel are, but I have been able to build ROOT on all forms of linux (arm and intel) until now.
Sorry, not much, but I hope that helps.
Josh