Error when verifying GPU is on when using PGI

Dear All

Recently I have installed PGI in a work station WITHOUT root permission, which means that I install PGI in my home directory. Upon installation, I tried to obtain the detail GPU information using pgaccelinfo -v, but the following shows up

CUDA Driver Version: 9000
could not initialize CUDA runtime, error code=999
No accelerators found.
Check the permissions on your CUDA device

I am quite fustrated because I am quite sure the graphic card is there by using lspci -nn | grep ‘[03’

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK110B [GeForce GTX TITAN Black] [10de:100c] (rev a1)

I would like to ask how would this happen, will it be related to my permission?



will it be related to my permission?

Possible, but error 999 just means “Unknown Error” so it could be any number of things.

While it’s been a number of years since I’ve heard of anyone having this problem, but with some older drivers, you used to have to run the CUDA driver once as root after each reboot in order to create a system module. Worked from non-root accounts after that. Please see this post on DevTalk for details:

Another thing to try is running “nvidia-smi” to gather info on your device. Pgaccelinfo uses the same device query so if that fails, then you may have an issue with your driver.

Finally, your card and CUDA driver (9.0) are fairly old. We don’t support CUDA 9.0 any longer. Not to say that it wont work, just that we no longer test it. You may try updating your CUDA driver and see if it helps.

Beat Regards,