Error with CAFFE?!

When i try to run digits, this message appears. I have spent the past 5 hours researching and trying to fix it. What should i do?

A valid Caffe installation was not found on your system.
Use the envvar CAFFE_ROOT to indicate a valid installation.
Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/home/mikulis/digits/digits/main.py”, line 70, in
main()
File “/home/mikulis/digits/digits/main.py”, line 53, in main
import digits.config
File “digits/config/init.py”, line 7, in
from . import ( # noqa
File “digits/config/caffe.py”, line 230, in
executable, version, flavor = load_from_path()
File “digits/config/caffe.py”, line 54, in load_from_path
raise ValueError(‘Caffe executable not found in PATH’)
ValueError: Caffe executable not found in PATH

Thanks,
Eric

Did you download Digits from NGC? How did you launch digits?

in terminal i typed…

cd digits

sudo ./digits-devserver

How did you install Digits?

from the website

Please download Digits from https://ngc.nvidia.com/catalog/containers/nvidia%2Fdigits.
The instruction should guide you toward launch.

so redownload digits?

Please launch Digits server per instruction given at https://ngc.nvidia.com/catalog/containers/nvidia%2Fdigits

ok thank you

ERROR: This container was built for NVIDIA Driver Release 410 or later, but
version 396.37 was detected and compatibility mode is UNAVAILABLE.

[[CUDA Driver UNAVAILABLE (cuInit(0) returned 999)]]


| _ / _ | | _ / |
| |) | | (
|| | | | _

|/_|||| |___/ 6.1.1

Caffe support disabled.
Reason: A valid Caffe installation was not found on your system.
Please check if CAFFE_ROOT environment variable is correctly set and pycaffe is built.
cudaRuntimeGetVersion() failed with error #35
2018-11-20 18:54:06 [INFO ] Loaded 0 jobs.

Hi,
I have the same error. When I start the server, there are a message about Caffe support disabled. I reinstaled many times. I try install with source and docker. The same error.

There are two DIGITS containers in each release. One includes tensorflow while the other one includes caffe. Please pull the caffe version of DIGITS. For example, the following command pulls the 19.01 release of DIGITS caffe container.

docker pull nvcr.io/nvidia/digits:19.01-caffe

Hi,

I pulled the DIGITS 19.04.caffe container successfully using:

docker pull nvcr.io/nvidia/digits:19.04-caffe

but when I attempt to run the container image:

nvidia-docker run -it --rm -v local_dir:container_dir nvcr.io/nvidia/digits:19.04-caffe

I get:

bash: nvidia-docker: command not found

How can I fix this?

Your docker installation was correct. However, in order to run nvidia-docker, you need to install something additional. Please see if you have nvidia docker runtime installed. This quickstart shall help you properly configure your host environment (https://github.com/NVIDIA/nvidia-docker#quickstart).

Please try to use docker run --runtime=nvidia instead of nvidia-docker run in the future.

Thank you…I followed the configuration instructions you provided (https://github.com/NVIDIA/nvidia-docker#quickstart) for Ubuntu 14.04/16.04/18.04

when I get to this step:

sudo apt-get install -y nvidia-docker2

I get:

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package nvidia-docker2

Earlier on in the process, when I ran,

sudo apt-get purge -y nvidia-docker

I got:

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package nvidia-docker

Appreciate your help

Likely your docker was the default version of Ubuntu. Can you check the docker version and maybe you need to pin a specific version of Docker (https://github.com/NVIDIA/nvidia-docker/wiki/Frequently-Asked-Questions#how-do-i-install-20-if-im-not-using-the-latest-docker-version)?

BTW, this seems to be a docker issue, not a DIGITS issue. It’s better to ask in our container technology forum.

Thanks…I will ask in the container technology forum.

A video walkthrough of natively installing NVIDIA DIGITS on Ubuntu 18.04 LTS is available here:

https://cudaeducation.com/nvidiadigits/

I personally have no desire to use a container or anything else to get DIGITS up and running. It is just another layer of complication that I don’t need. I already have enough moving parts as it is. Even to do a native install, there is a long list of requirements.

I was able to successfully follow the tutorials here: https://github.com/dusty-nv/jetson-inference#system-setup once NVIDIA DIGITS was installed natively.

Hope this helps!

-Cuda Education
cudaeducation.com