Fan issue

is there a way to manually trigger the fan somehow?
at some point [ maybe after zed installaton], I noticed that it won’t spin, regardless [jetsonclocks etc]

 cat /sys/devices/generic_pwm_tachometer/hwmon/hwmon1/rpm
root@nvidia-desktop:/sys/kernel/debug# echo 255 |  tee /sys/devices/generic_pwm_tachometer/hwmon/hwmon1/rpm
tee: /sys/devices/generic_pwm_tachometer/hwmon/hwmon1/rpm: Permission denied
root@nvidia-desktop:/sys/kernel/debug# echo 255 >/sys/devices/generic_pwm_tachometer/hwmon/hwmon1/rpm
bash: /sys/devices/generic_pwm_tachometer/hwmon/hwmon1/rpm: Permission denied

Upd: when device got overheated it started spinning;

 cat /sys/devices/generic_pwm_tachometer/hwmon/hwmon1/rpm

but it would be handy to recover the option to start the fan without reflashing the OS, if possible

hello Andrey1984,

there’s behavior changes starting with release l4t-r32.4.3, jetson_clocks no longer sets maximum fan speed by default.
you’ll need to specify --fan option if you prefer the old behavior; please also refer to developer guide, Maximizing Jetson Xavier Performance, for reference

you might also have a try to configure target_pwm via hardware monitor.
for example,
$ echo 255 > /sys/class/hwmon/hwmon2/target_pwm

Thanks @JerryChang,
it got much better when it spins without overheating