Farm Agent idle on another machine

Hello, me and my co-worker tried to create a small render farm of 2 machines for our Create rendering task. The Farm Agent on his machine connected successfully to my Farm Queue. But when I submitted my scene to the Queue, only my Agent started rendering, while his Agent stayed idle.

I tried to set the batch number to 2 but it didn’t help. Do I need to install a Nucleus server or something?

It would be nice if someone tell me what am I missing.

Hello @user79641! I will need some more information from you to help figure out where the problem is happening.

  • What is the Operating System and GPU / GPU Driver for your 2 machines?
  • What versions of Farm Queue and Farm Agent are you using?
  • In your Farm Queue Manager Dashboard, you should see an icon for “Logs”. Could you grab a copy of those logs for both machines and attach them here?
  • What are the steps you are taking when you send a job to the queue?

For now, i can point you to the Omniverse Farm Agent and Farm Queue Configuration documentation. There is a Troubleshooting section on that page that may help.

Hello!

  • We have Ryzen 7 and 64GB Ram, 3060. I think we have different driver versions. I’ll have to check the machines next week.
  • We both have the previous version (we noticed there was an update yesterday or so, but didn’t update).
  • I’ll try to copy the log next week.
  • I sent to queue from Create movie capture.