Flash module

I set the driver generation module in the .config file, how can I flash the generated .ko file into the TX2? Is there a way to flash without changing the original system?

thank you!!

You can refer to the document.


7.Execute the following commands to install the kernel modules:
$ sudo make ARCH=arm64 O=$TEGRA_KERNEL_OUT modules_install \

I have generated the .ko file and the installation of the kernel module is done. How to flash the module into TX2 after that? Just need the flash module, don’t change other things in TX2

No method to “only flash the module”.

The module is in the rootfs, so you can only flash the whole APP partition.

Is it only possible to use the command “sudo ./flash jetson-tx2 mmcblk0p1”? In this case, after brushing, there is only a simple system left.

Sorry that don’t understand what you are talking about…

flash command will create the system image from the rootfs again. If your kernel module is really in rootfs, then it will appear in the system after flash.

I now want to update the .ko file in rootfs with minimal cost (no need to re-flash the whole system).

Can you provide the corresponding command to refresh each partition and what files are changed after the refresh. For example: use the command “sudo ./flash -k kernel-dtb jetson-tx2 mmcblk0p1” to refresh the device tree, after the refresh is complete, only change the device tree file of TX2


You can refer to the flash.xml under your Linux_for_Tegra/bootloader. That is the partition layout.

If you just want to update one file, my suggestion is just use ethernet or something else to send your ko file to the device… There is no need to “flash” just for one file. It is like using cannon to hit a bird.

My understanding is: after copying, insmod is still required, which is very convenient in the debugging stage. After debugging, it can be installed after programming, so I want to know the flash command.

I already said, kernel module is in the rootfs which is for APP partition. If you just want to flash this one, run command.

sudo ./flash.sh -k APP jetson-tx2 mmcblk0p1.

But this one will flash the whole file system. And this one takes the most of time. Has no much diff between this one and full flash.

OK, thank you!!

hello, completed mass flash of jetson-nano by following the nvmassflash.txt and so as tried flashing multiple jetson-tx2-nx but ended up getting a prompt “Flash completed (with errors)” and checked it if the flash has completed and it didn’t worked.So is there any another method of flashing tx2-nx?

And also wanted to confirm which device name to be used when flashing in online method like:" jetson-tx2-devkit" i have b een using ubuntu 20.1 with jetpack versoin 4.5.1 .

Thank you

Please file your own topic.