Forward compatibility was attempted on non supported HW in function

Hi,

im using Ubuntu 20.04 with docker (host and container 20.04). The base-image is nvidia/cuda:11.3.0-cudnn8-devel-ubuntu20.04.

Building my application works, but when running it i will get an error from within opencv (4.5.2)

terminate called after throwing an instance of 'cv::Exception'
what():  OpenCV(4.5.2) /build/opencv-4.5.2/modules/core/src/cuda/gpu_mat.cu:116: error: (-217:Gpu API call) forward compatibility was attempted on non supported HW in function 'allocate'

On the host driver 450.119.03 is installed, which seems to be sufficient, see CUDA Compatibility :: GPU Deployment and Management Documentation (for 11.3 >= 450.80.02 is needed)

nvidia-smi on host:
±----------------------------------------------------------------------------+
| NVIDIA-SMI 450.119.03 Driver Version: 450.119.03 CUDA Version: 11.0 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce GTX 166… Off | 00000000:01:00.0 Off | N/A |
| N/A 46C P8 6W / N/A | 647MiB / 5944MiB | 27% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

nvidia-smi on container:
±----------------------------------------------------------------------------+
| NVIDIA-SMI 450.119.03 Driver Version: 450.119.03 CUDA Version: 11.3 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce GTX 166… Off | 00000000:01:00.0 Off | N/A |
| N/A 46C P5 10W / N/A | 647MiB / 5944MiB | 29% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

Since the driver version is sufficient there should be no forwarding attempt at all. Am i doing something wrong?

Edit: The driver on host system was installed from ubuntu repositories (nvidia-driver-450)
Edit2: Docker is also the default one (docker.io) in verison 20.10.2. And i am running the container with --gpus all. nvidia-container-toolkit is installed in version 1.4.2-1

After deploying a binary which was build in docker on a “real” ubuntu 20.04 with installed driver 460.xx i also faced problems which could be only solved by installing the latest driver 466.xx. Is the compatiblity list in CUDA Compatibility :: GPU Deployment and Management Documentation wrong?