FPS drops when source is added/removed on runtime with new streammux

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) - GPU
• DeepStream Version - 6.1
• JetPack Version (valid for Jetson only)
• TensorRT Version - 8.4.1
• NVIDIA GPU Driver Version (valid for GPU only) - 520.61.05

I use uridecodebin with multiple input rtsp sources. I have a logic of runtime addition/deletion of sources if a particular source becomes unavailable. I connect to videotestsrc in case a particular source becomes unavailable and swap it back to the pipeline once it becomes available. I have no issues with this application if I use old nvstreammux.
But if I use new streammux by setting export USE_NEW_NVSTREAMMUX=yes, the FPS keeps dropping whenever I add/delete source at runtime.
Note: I haven’t encountered this FPS drop when I use the new nvstreammux on the runtime addition/deletion reference application. Problem is just with my application. Please let me know if I’m missing something.

Is this the same as https://forums.developer.nvidia.com/t/deepstream-app-slows-if-any-of-the-rtsp-sources-become-flaky/237092? If they are same, please close one of them. Thanks

No, both are different issues

Any lead on this please?

Could you minimize your source code and attach to us?

Attaching the functions for runtime addition and deletion of source for reference.
connect_dummy_src() function takes care of deleting the rtsp source and swapping it with videotestsrc.
reconnect_rtsp_src() function takes care of swapping videotestsrc with uridecodebin once the connection is back. These two functions run at separate threads.
snippet.cpp (12.2 KB)

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

Sorry, I may not have described it clearly. Could you minimize your source code that can run and reproduce the problems? You can attach here or just message me. Thanks

This is not an issue anymore. After setting the new configuration for streammux, this issue is resolved. Thanks.

Hi, can you share more about “new configuration for streammux”. Thanks

@v.hunglx2, Below is the new configuration:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.