Garbage video output with XBMC/openSUSE 12.3/319.12

I’ve tried using the latest Nvidia drivers (319.12) and upon trying to watch any video, regardless of renderer (software, vdpau, shaders) all video gives me a screen like such:

Here is the log file:

http://www.pastebin.ca/2363879

Rolling back to the 313.30 drivers resolves the issue but the issue only appears in XBMC (other players such as mplayer2, xine, vlc, etc work fine). Going fullscreen will completely lock up the system.

I have tried the latest XBMC GIT and the issue remains (debug logs and screen shot are from the openSUSE 12.3 packages).
I have also tried this on the Geforce GT-520 running openSUSE 12.2 and the same situation there.

Any ideas?

Any word on a fix for this? I didn’t see anything specific in the 319.17 release notes to address this.

Issue still exists with 319.17 drivers. Can we please get someone from nvidia to chime in on this?

I am having the same problem here with a GeForce 560ti card. I haven’t had any issues in the year leading up to installing this driver. I ran apt-get autoremove and deleted all remnants of xbmc and then reinstalled. It didn’t help. I am experiencing the same issues due to the 319.17 driver.

There is something funky going on with the permissions with the 319.xx series drivers. It seems running as root allows xbmc to playback fine.

http://forum.xbmc.org/showthread.php?tid=164436&page=2

I can confirm this issue. I am having exactly the same problem since the latest nVidia and XBMC updates.

I am running OpenSUSE 12.3 x86_64 on a Pentium 4HT
nVidia GT 520 video card
xbmc-12.1-1.11 x86_64
nvidia-gfxG03-310.44-11.1

xbmc output log
http://pastebin.com/LkKXnvZR