GeForce 1080 Ti not detected after reboot

I have an NVIDIA GeForce 1080 Ti working fine on Ubuntu 16.04.

After a power outage a couple days ago, it stopped working: nvidia-smi not working and GPU not found in lspci/lsmod. After rebooting the machine a couple of times and shutting off for a couple of hours, it worked again out of nowhere.

I reboot the machine today and I have the same issue : nvidia-smi not working and GPU not found in lspci/lsmod/lshw. I tried to re-install the drivers 384 and 390, to install nvidia-modprobe, update pciids, but it doesn’t work either.

The output of lspci -nn | grep ‘[03’ is the Intel Graphic card.

Thank you very much for any help !

sounds like a broken GPU.

recheck slot insertion, and connection of aux power cables to the GPU.

It seems to physically work and to be on.
I have checked in the BIOS, the Graphics Configuration setting, I have set the Primary Display parameter to PCIE (instead of CPU Graphics) but it goes back to Auto when rebooting the computer.

I have opened the server and remove the dust inside and it seems to work now.
I don’t know if it’s possible that the dust was the culprit.

Accumulation of dust can interfere with actively cooled components, i.e. anything with a fan, like a GPU. I cannot offer plausible scenarios how that would lead to the card being recognized only intermittently. A more likely physical cause of such intermittent failures are poor contacts at the slot connector, as txbob pointed out.

This could be due to dirt on or corrosion of the contacts on the GPU or bent pins inside the connector on the motherboard. Often simply pulling the card and re-inserting it will fix the problem. Don’t forget to secure the GPU mechanically with whatever mechanism is provided (screw, clamping lever, etc). In rarer cases, a motherboard/GPU connector might be negatively impacted by strong vibrations, e.g. when operating a computer in a ship or on a factory floor.