GigE camera streamer not working beyond 12fps

I’m using a gigE cameras on jetson tx2 which is running on jetpack4.2.2.
I have an issue with camera streaming. In my application, I want the camera to stream with 14 fps in rawbayer mode. But the camera frames are dropping beyond 12fps in all nvpmodes except nvpmod 1.

Could you also run the jetson_clocks after run the nvpmodel.

I had set jetson clocks yet the camera has frame drops.
I had opened an issue on the same topic which wasn’t solved yet. Please take a look at this issue Tx2 eth port can’t handle high incoming traffic: GigE stream issue

Could you check the /etc/nvpmodel.conf, how many CPU cores are enabled.

I had checked the nvpmodel. I don’t understand how to check if all cpu’s are enabled using this conf file. I’m attaching the file here for your reference.
tegrastats shows all cpus are upnvpmodel.log|attachment (15.2 KB) nvpmodel.log (15.2 KB)

The nvpmodel -m 1 enable 3 CPU cores but -m 0 enable more CPU cores.
The problem could be the EMC MAX_FREQ or GPU MAX_FREQ, could you modify this two in others mode to confirm it, and try to narrow down which parameter help on it.

< POWER_MODEL ID=1 NAME=MAXQ >
CPU_ONLINE CORE_1 0
CPU_ONLINE CORE_2 0
CPU_ONLINE CORE_3 1
CPU_ONLINE CORE_4 1
CPU_ONLINE CORE_5 1
CPU_A57 MIN_FREQ 0
CPU_A57 MAX_FREQ 1200000
GPU MIN_FREQ 0
GPU MAX_FREQ 850000000
EMC MAX_FREQ 1331200000

Below config does the job.

# MAXN is the NONE power model to release all constraints                          

< POWER_MODEL ID=0 NAME=MAXN >
CPU_ONLINE CORE_1 1
CPU_ONLINE CORE_2 1
CPU_ONLINE CORE_3 1
CPU_ONLINE CORE_4 1
CPU_ONLINE CORE_5 1
CPU_A57 MIN_FREQ 0
CPU_A57 MAX_FREQ -1
CPU_DENVER MIN_FREQ 0
CPU_DENVER MAX_FREQ 990000
GPU MIN_FREQ 0
GPU MAX_FREQ -1
EMC MAX_FREQ -1

Reducing denver frequency and increasing EMC max_frequency does the job. But I’m not sure how this will affect MAXN performance.

I think the key point should be the EMC, could you double confirm it?

Thanks

I can confirm that it is not EMC that is the key point.
It is denver MAX_FREQ :)

OK, I would suggest to disable denver core to check if enable denver may hurt performance.

Disabling denver cores is not a preferred a solution for me. There is any solution or side I should take a look into?

What if I tune denver frequency? How this will have an effect on the system? Can you explain?

Hi,

Please check 5.16 Increased Kernel Launch Latency on Denver 2 Cores in release notes 6 of r32.4.3.
Due to the concern, we disable Denver cores by default.