Google Colab ssd.ipynb no python3.6

We’re checking. Will update to you if any. Thanks.

1 Like

Same issue. Is there any update?
@Morganh

1 Like

Hi,
It is due to Ubuntu default version being 22.04 in colab now, which doesn’t support python 3.6 via deadsnakes like we do for ubuntu 20.04.
Internal team are still working on that.

1 Like

Hello Morgan,
Is it possible use Ubuntu 20.04 on Colab? Fallback version is no more available.

Hi @Morganh,
I have the same issue, is there any news?

TAO team is working on that. Will update to you if there is any news. Thanks.

1 Like

I have encountered the same issue as well. Is there any update?

Currently, the Ubuntu version in colab has been changed to 22.04. But fallback runtime is no more available.
For TAO, it is expected to run in Ubuntu 20.04 or 18.04. TAO Toolkit Quick Start Guide - NVIDIA Docs .

For temporary workaround, please try to run TAO on local dgpu machine or cloud machine.

https://docs.nvidia.com/tao/tao-toolkit/text/tao_toolkit_quick_start_guide.html#hardware-requirements
https://docs.nvidia.com/tao/tao-toolkit/text/running_in_cloud/overview.html

Is there a current fixed yet for Colab tao tool kit. Cause I am getting the same errors too.

2 Likes

@user146261 have you managed to find a solution? I am getting the same errors.

For temporary workaround, please try to run TAO on local dgpu machine or cloud machine. We have not figure out yet since colab is updated to Ubuntu22.04 which does not allow to use fallback runtime.

Hi, I have encountered the same issue. Is there any update for Colab?

Hi, truth be told I just abandoned TAO and use colab normally.
You can export the model.pt you train on COLAB and implement in any Jetson without problem. I lost a huge amount of time trying to work around this problem.

Thank you for your reply. How did you prun on colab without using TAO?

Good question.
I didn’t. Using Jetson nano I am able to run YOLOv8 at 20fps and Jetson Nano Orin at over 60fps. So I just didn’t need to prune anything.

This will clearly depend on which application you are aiming at. But please let me know if you find a way to prune the model.
Cheers

1 Like

Note: Currently, the colab notebooks can work now on ubuntu22.04.
Please run notebooks in Running TAO Toolkit on Google Colab - NVIDIA Docs

More info can be found in GitHub - NVIDIA-AI-IOT/nvidia-tao.