GPU has fallen off the bus

Hello, recently my system started hanging up. Screen freezes and computer do not respond to input (even num lock diode does not respond). Every time I get this output in the system journal:

maj 28 21:01:30 hostname kernel: NVRM: GPU at PCI:0000:01:00: GPU-a731925c-74f1-27c5-a425-05a2194d1054
maj 28 21:01:30 hostname kernel: NVRM: Xid (PCI:0000:01:00): 79, pid=0, GPU has fallen off the bus.
maj 28 21:01:30 hostname kernel: NVRM: GPU 0000:01:00.0: GPU has fallen off the bus.
maj 28 21:01:30 hostname kernel: NVRM: A GPU crash dump has been created. If possible, please run
                                      NVRM: nvidia-bug-report.sh as root to collect this data before
                                      NVRM: the NVIDIA kernel module is unloaded.

After this kernel keeps running and registers peripheral hardware changes. I do not perform heavy tasks so it is not overheating or power delivery problem. I use optimus-manager in Nvidia-only mode. Nevertheless I can spot GPU falling off buf in logs before installing optimus-manager. I tried rolling back to kernel 5.10 but issue persisted.

I made script to create bug report when problem occurs. Here is the output:
1_nvidia-bug-report.log.gz (221.7 KB)

My system specs:

System:    Kernel: 5.12.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 root=UUID=e1af91cc-b586-44c3-be27-b334d7db6d78 rw quiet apparmor=1 
           security=apparmor resume=UUID=b8f36652-e94c-41c9-b836-207612eadcd0 udev.log_priority=3 
           Console: tty pts/1 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20378 v: Lenovo Y50-70 serial: <filter> Chassis: type: 10 v: Lenovo Y50-70 
           serial: <filter> 
           Mobo: LENOVO model: Lenovo Y50-70 v: 00000000NO DPK serial: <filter> UEFI: LENOVO v: 9ECN43WW(V3.03) 
           date: 08/12/2015 
CPU:       Info: Quad Core model: Intel Core i7-4720HQ socket: LGA1150 (U3E1) note: check bits: 64 type: MT MCP arch: Haswell 
           family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: L1: 64 KiB L2: 6 MiB L3: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41524 
           Speed: 2594 MHz min/max: 800/3600 MHz base/boost: 2600/2600 volts: 0.8 V ext-clock: 100 MHz Core speeds (MHz): 
           1: 2594 2: 2398 3: 1882 4: 2189 5: 1219 6: 1485 7: 1046 8: 1561 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:0416 class-ID: 0300 
           Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Lenovo driver: nvidia v: 460.80 alternate: nouveau,nvidia_drm 
           bus-ID: 01:00.0 chip-ID: 10de:139b class-ID: 0302 
           Device-3: Syntek Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 3-6:2 chip-ID: 174f:14b8 class-ID: 0e02 
           serial: <filter> 
           Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: GeForce GTX 960M/PCIe/SSE2 v: 4.6.0 NVIDIA 460.80 direct render: Yes 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 38 C 
           Fan Speeds (RPM): N/A

Thanks for the help.