GPUDirect RDMA on X86 linux PC, driver build issue

I am trying to do GPUDirect RDMA mentioned the below link. I am using an X86 linux PC with Quadro M4000 GPU and CUDA 12.0 tool kit.

When ran command “./”, get the following error:
Building modules, stage 2.
** MODPOST 1 modules**
FATAL: parse error in symbol dump file
scripts/Makefile.modpost:92: recipe for target ‘__modpost’ failed
make[2]: *** [__modpost] Error 1
Makefile:1678: recipe for target ‘modules’ failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-5.4.0-136-generic’
Makefile:19: recipe for target ‘modules’ failed
make: *** [modules] Error 2

To avoid the above error, I ran “./” this command the module is built and loaded.
But again, I get error when I ran the command “client-applications/./”,
make: Nothing to be done for ‘default’.

Ignoring this error when I ran the data acess test given the above github link, I do not get an error while running the command “./rdma-malloc”. But, I get the following error, when I ran this command “./rdma-cuda”,
ioctl(PIN_CUDA src) failed: ret=-1 errno=22.

Again when I did the "set leds test, if I use command "./set-leds 7, I get an error “open() failed: Permission denied”, but when I use “sudo” before the command, i don’t get an error.

Kindly, anyone who knows reply to this thread for the above errors and why they are occuring?

GPU Driect support on TESLA GPU.

@xiaofengl GPU Driect support on TESLA GPU?
I think you forgot provide any link or I did not get your answer.

Kindly, anyone who knows the cause for the above errors and why they are occurring? reply to this thread.

Kindly reply,
Driver version - NVIDIA-Linux-x86_64-525.78.01
kernel version - 5.4.0-137-generic
These kernel and driver versions are compatible to build the picoevb module or not?