GStreamer Installation error

Hi All,

I am getting below error when trying to install GStreamer on my target device - Jetson AGX Xavier Industrial.
I am running kernel 5.10.120-tegra and linux version is 35.4.1.

root@trident-desktop:/home/trident/Downloads# sudo apt-get install gstreamer-1.0-tools gstreamer1.0-alsa gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-plugins-bad gstreamer1.0-libav
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package gstreamer-1.0-tools
E: Couldn’t find any package by glob ‘gstreamer-1.0-tools’
E: Couldn’t find any package by regex ‘gstreamer-1.0-tools’

Please let me know, how to resolve these errors. I am installing this to test my Eco Capture card , which is connected to my SOM module via mPCI/M2 slot and the other side it is connected to a SDI interface based camera for testing.

$sudo apt-get install libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-qt5 gstreamer1.0-pulseaudio

This command seems to install some stuff successfully.

The package name should be gstreamer1.0-tools instead of gstreamer-1.0-tools

1 Like

Thanks, it worked.

Could you please help me on further steps( any helpful link), where I need to use GStreamer player to test by camera connected to my Video grabber card via SDI interface through PAL/NTSC.

what commands should we use?


If the camera input supports v4l2, please refer to Jetson Nano FAQ

Q: I have a USB camera. How can I launch it on Jetson Nano?

For more sample commands, please check
Accelerated GStreamer — Jetson Linux Developer Guide documentation

1 Like

Thanks for the updates. I shall refer these links during the process of testing my MageWell eco capture card connected to SDI camera.


I am getting below error, when I run the command xinit & :

Any idea what may be the reason.

These steps are mentioned in the file “nvgstplayer-1.0_README…txt” present in the directory


root@localhost:/home/trident/Downloads# ls
EcoCaptureForLinuxTX2_1.4.187 EcoCaptureForLinuxTX2_1.4.187.tar.gz
root@localhost:/home/trident/Downloads# export DISPLAY=:0
root@localhost:/home/trident/Downloads# xinit &
[1] 5268
_XSERVTransSocketUNIXCreateListener: …SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn’t already running(EE)
Please consult the The X.Org Foundation support
for help.
(EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
(EE) Server terminated with error (1). Closing log file.
X connection to :0 broken (explicit kill or server shutdown).

If you use default rootfs, Ubuntu desktop is enabled and you don’t need to initialize X Window. You may ignore the step and try gstreamer commands in developer guide.

1 Like

Thanks. Its working fine.
I was able to execute Glauncher application command successfully and see the video on the window.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.