Gstreamer - Jetson Orin Nano - RTSP

Hi I’ve really struggled to get gstreamer to outperfom Open CV.

The source is a 4k 25 fps h264 stream at around 16mbps bitrate.

OpenCV, using cv2.VideoCapture(source) can capture 25fps but the max I can get with streamer is 20 fps.

Here is my pipeline,
'rtspsrc location=rtsp://xxxx/Streaming/Channels/101 latency=150 ! ’
'rtph264depay ! h264parse ! ’
'nvv4l2decoder enable-max-performance=1 ! ’
'nvvidconv ! ’
'video/x-raw, format=(string)BGRx ! ’
'videoconvert ! ’
'video/x-raw, format=(string)BGR ! ’
run with cv2.VideoCapture(gstreamer_pipeline, cv2.CAP_GSTREAMER)

Has anyone ran into the same issue when trying to use RTSP with GStreamer on a jetson orin nano devkit?
Any pipeline improvements would be greatly appreciated.

My goal was to free up processing power by moving the decoding and reading of the stream to the special hardware on the device, to use for other processes.

Please provide complete information as applicable to your setup. Thanks
Hardware Platform (Jetson / GPU)
DeepStream Version
JetPack Version (valid for Jetson only)
TensorRT Version
NVIDIA GPU Driver Version (valid for GPU only)
Issue Type( questions, new requirements, bugs)
How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hardware Platform (Jetson / GPU)
Jetson Orin Nano Devkit

JetPack Version (valid for Jetson only)

Issue Type( questions, new requirements, bugs)

How to reproduce the issue ?
Use pipeline on 4k 25fps h264 stream

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

The videoconvert plugin may affect the frame rate. Could you just use nvvideoconvert as follows?

'nvv4l2decoder enable-max-performance=1 ! ’
'nvvideoconvert ! ’
'video/x-raw, format=(string)BGR ! ’

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.