GTX 1080, CUDA 8.0 on Linux Mint 18 problems setting up

Have installed the latest drivers 367.35 and am using the latest CUDA 8.0 RC.

$ nvidia-smi 
Mon Aug  8 14:16:24 2016       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 367.35                 Driver Version: 367.35                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1080    Off  | 0000:01:00.0      On |                  N/A |
| 10%   48C    P0    40W / 200W |    557MiB /  8105MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|    0      1232    G   /usr/lib/xorg/Xorg                             369MiB |
|    0      2036    G   cinnamon                                        77MiB |
|    0      2376    G   ...s-passed-by-fd --v8-snapshot-passed-by-fd   108MiB |
$ nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2016 NVIDIA Corporation
Built on Wed_May__4_21:01:56_CDT_2016
Cuda compilation tools, release 8.0, V8.0.26

Tryna use the deviceQuery from CUDA 8.0 samples fails as shown below:

$ ./deviceQuery
./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

Out of ideas. What on earth is the reason for insufficient version? I’ve shown i’m using the latest drivers and CUDA toolkit above. There are no other versions on the system. Been banging my head on this for 3 days straight. Am beyond frustrated…

I can verify i’m using the right drivers… and have clean installed the CUDA stuff a million times etc.

ps. I have also tried using 7.5 but that did not work either. Same issues.

I used the runfile method to install the toolkit. I installed the nvidia driver via PPA.

I suspect it’s related to no being able to find libcuda.so.1

30716:	transferring control: ./deviceQuery
     30716:	
     30716:	symbol=printf;  lookup in file=./deviceQuery [0]
     30716:	symbol=printf;  lookup in file=/lib/x86_64-linux-gnu/librt.so.1 [0]
     30716:	symbol=printf;  lookup in file=/lib/x86_64-linux-gnu/libpthread.so.0 [0]
     30716:	symbol=printf;  lookup in file=/lib/x86_64-linux-gnu/libdl.so.2 [0]
     30716:	symbol=printf;  lookup in file=/usr/lib/x86_64-linux-gnu/libstdc++.so.6 [0]
     30716:	symbol=printf;  lookup in file=/lib/x86_64-linux-gnu/libgcc_s.so.1 [0]
     30716:	symbol=printf;  lookup in file=/lib/x86_64-linux-gnu/libc.so.6 [0]
     30716:	binding file ./deviceQuery [0] to /lib/x86_64-linux-gnu/libc.so.6 [0]: normal symbol `printf' [GLIBC_2.2.5]
./deviceQuery Starting...

     30716:	symbol=puts;  lookup in file=./deviceQuery [0]
     30716:	symbol=puts;  lookup in file=/lib/x86_64-linux-gnu/librt.so.1 [0]
     30716:	symbol=puts;  lookup in file=/lib/x86_64-linux-gnu/libpthread.so.0 [0]
     30716:	symbol=puts;  lookup in file=/lib/x86_64-linux-gnu/libdl.so.2 [0]
     30716:	symbol=puts;  lookup in file=/usr/lib/x86_64-linux-gnu/libstdc++.so.6 [0]
     30716:	symbol=puts;  lookup in file=/lib/x86_64-linux-gnu/libgcc_s.so.1 [0]
     30716:	symbol=puts;  lookup in file=/lib/x86_64-linux-gnu/libc.so.6 [0]
     30716:	binding file ./deviceQuery [0] to /lib/x86_64-linux-gnu/libc.so.6 [0]: normal symbol `puts' [GLIBC_2.2.5]
 CUDA Device Query (Runtime API) version (CUDART static linking)

     30716:	symbol=dlopen;  lookup in file=./deviceQuery [0]
     30716:	symbol=dlopen;  lookup in file=/lib/x86_64-linux-gnu/librt.so.1 [0]
     30716:	symbol=dlopen;  lookup in file=/lib/x86_64-linux-gnu/libpthread.so.0 [0]
     30716:	symbol=dlopen;  lookup in file=/lib/x86_64-linux-gnu/libdl.so.2 [0]
     30716:	binding file ./deviceQuery [0] to /lib/x86_64-linux-gnu/libdl.so.2 [0]: normal symbol `dlopen' [GLIBC_2.2.5]
     30716:	symbol=calloc;  lookup in file=./deviceQuery [0]
     30716:	symbol=calloc;  lookup in file=/lib/x86_64-linux-gnu/librt.so.1 [0]
     30716:	symbol=calloc;  lookup in file=/lib/x86_64-linux-gnu/libpthread.so.0 [0]
     30716:	symbol=calloc;  lookup in file=/lib/x86_64-linux-gnu/libdl.so.2 [0]
     30716:	symbol=calloc;  lookup in file=/usr/lib/x86_64-linux-gnu/libstdc++.so.6 [0]
     30716:	symbol=calloc;  lookup in file=/lib/x86_64-linux-gnu/libgcc_s.so.1 [0]
     30716:	symbol=calloc;  lookup in file=/lib/x86_64-linux-gnu/libc.so.6 [0]
     30716:	binding file /lib/x86_64-linux-gnu/libdl.so.2 [0] to /lib/x86_64-linux-gnu/libc.so.6 [0]: normal symbol `calloc' [GLIBC_2.2.5]
     30716:	
     30716:	file=libcuda.so.1 [0];  dynamically loaded by ./deviceQuery [0]
     30716:	find library=libcuda.so.1 [0]; searching
     30716:	 search path=/usr/local/cuda-8.0/lib64		(LD_LIBRARY_PATH)
     30716:	  trying file=/usr/local/cuda-8.0/lib64/libcuda.so.1
     30716:	 search cache=/etc/ld.so.cache
     30716:	 search path=/lib/x86_64-linux-gnu/tls/x86_64:/lib/x86_64-linux-gnu/tls:/lib/x86_64-linux-gnu/x86_64:/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnu/tls/x86_64:/usr/lib/x86_64-linux-gnu/tls:/usr/lib/x86_64-linux-gnu/x86_64:/usr/lib/x86_64-linux-gnu:/lib/tls/x86_64:/lib/tls:/lib/x86_64:/lib:/usr/lib/tls/x86_64:/usr/lib/tls:/usr/lib/x86_64:/usr/lib		(system search path)
     30716:	  trying file=/lib/x86_64-linux-gnu/tls/x86_64/libcuda.so.1
     30716:	  trying file=/lib/x86_64-linux-gnu/tls/libcuda.so.1
     30716:	  trying file=/lib/x86_64-linux-gnu/x86_64/libcuda.so.1
     30716:	  trying file=/lib/x86_64-linux-gnu/libcuda.so.1
     30716:	  trying file=/usr/lib/x86_64-linux-gnu/tls/x86_64/libcuda.so.1
     30716:	  trying file=/usr/lib/x86_64-linux-gnu/tls/libcuda.so.1
     30716:	  trying file=/usr/lib/x86_64-linux-gnu/x86_64/libcuda.so.1
     30716:	  trying file=/usr/lib/x86_64-linux-gnu/libcuda.so.1
     30716:	  trying file=/lib/tls/x86_64/libcuda.so.1
     30716:	  trying file=/lib/tls/libcuda.so.1
     30716:	  trying file=/lib/x86_64/libcuda.so.1
     30716:	  trying file=/lib/libcuda.so.1
     30716:	  trying file=/usr/lib/tls/x86_64/libcuda.so.1
     30716:	  trying file=/usr/lib/tls/libcuda.so.1
     30716:	  trying file=/usr/lib/x86_64/libcuda.so.1
     30716:	  trying file=/usr/lib/libcuda.so.1
     30716:	
     30716:	symbol=pthread_mutex_lock;  lookup in file=./deviceQuery [0]
     30716:	symbol=pthread_mutex_lock;  lookup in file=/lib/x86_64-linux-gnu/librt.so.1 [0]
     30716:	symbol=pthread_mutex_lock;  lookup in file=/lib/x86_64-linux-gnu/libpthread.so.0 [0]
     30716:	binding file ./deviceQuery [0] to /lib/x86_64-linux-gnu/libpthread.so.0 [0]: normal symbol `pthread_mutex_lock' [GLIBC_2.2.5]
     30716:	symbol=pthread_mutex_unlock;  lookup in file=./deviceQuery [0]
     30716:	symbol=pthread_mutex_unlock;  lookup in file=/lib/x86_64-linux-gnu/librt.so.1 [0]
     30716:	symbol=pthread_mutex_unlock;  lookup in file=/lib/x86_64-linux-gnu/libpthread.so.0 [0]
     30716:	binding file ./deviceQuery [0] to /lib/x86_64-linux-gnu/libpthread.so.0 [0]: normal symbol `pthread_mutex_unlock' [GLIBC_2.2.5]
cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

I don’t think linux mint 18 is an officially supported distro for CUDA 8.

I would suggest starting over with the method I described here:

https://devtalk.nvidia.com/default/topic/955414/cuda-setup-and-installation/-solved-how-to-install-titan-x-pascal-driver-on-top-of-cuda-8-/

In particular, install the driver using the runfile installer using the installer downloaded from www.nvidia.com. Don’t use the PPA method for driver install.

I would rather use Linux Mint because i can’t stand Unity on Ubuntu. Any reason you think using the runfile installer will make any difference? I installed it using the same PPA method on Ubuntu 16.04 and CUDA 8.0 works fine with 16.04. I’m at a loss what’s different between the two distros. Thanks for your help.

So on 16.04, gcc --version returns 5.3.1 and on Mint 18 it returns 5.4.0. Cud it be this? I know to make the samples compile i had to modify a systems header which checks and errors on higher gcc version. Did not need to do that on Ubuntu. Hmm.

nevermind. i already ruled this out earlier when i tried executing the sample binaries built using 16.04 on Mint18 and vice versa. The binaries built on Mint ran perfectly on 16.04 but the 16.04 ones did not run on Mint. So I doubt it’s about GCC.

Any other ideas?? I’m losing my mind…

[I’d like to see a place for driver / application reports]

Which driver for Ubuntu Linux (Linux MINT 18) offers the best thermal control settings?

Having a problem with GPU temps on Linux MINT 18 (fan speeds not controllable via nvidia-settings
in /usr/sbin/nvidia-settings

Updated from Linux Mint 17.2, where things we basically working.

Now I fear that my GPU fan settings won’t ever be under good control.
Here is the nvidia-smi output.
root@ralphopt ~ # nvidia-smi
Sat Nov 19 22:36:04 2016
±----------------------------------------------------------------------------+
| NVIDIA-SMI 375.20 Driver Version: 375.20 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 950 Off | 0000:01:00.0 On | N/A |
| 0% 38C P0 23W / 125W | 287MiB / 2028MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 1 GeForce GTX 950 Off | 0000:02:00.0 Off | N/A |
| 0% 24C P8 6W / 125W | 1MiB / 2028MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1403 G /usr/lib/xorg/Xorg 243MiB |
| 0 2260 G cinnamon 41MiB |
±----------------------------------------------------------------------------+