Help me,please. GTX-Titan doesn't work well.

I am a beginner in both CUDA, English.
I will be able to read English, but to write it is not good.
So, this article has also been automatically translated.

I’ve created a CUDA program.
It seems to work well with GTX-580@CUDA5.0 and -arch sm_13 option.
However, it is not working well with GTX-Titan@CUDA5.5 and -arch sm_35 option.
Calculation accuracy is getting worse about two orders of magnitude.
It is set to double precision mode in nvidia-settings.

Hi,
can you post the source code, and describe how do you compile it?
Are you compiling manually using nvcc, or in Visual Studio, or something else?
The -arch= is the only option you are using when compiling?

Hello,

I am not sure what is the problem, but there is a bug in older drivers so you need to install the appropriate one. I use now this one http://www.nvidia.com/object/linux-display-amd64-325.15-driver.html and I have no more problem on 2different computer with linux ( thanks mfatica and nvidia).

hrvthzs , pasoleatis >

Thank you!

hrvthzs >

Sorry,it is not possible to post the source code.
I’m compiling manually using nvcc for *.cu file and gcc for *.c file with openSUSE12.2.
And I link them by gcc.
It is as follows.

gcc -c -Os -ltcmalloc -fopenmp -lstdc++ xxxx.c
nvcc -c -arch sm_35 -ccbin /usr/bin/gcc -Xcompiler “-fopenmp -Os -ltcmalloc” yyyy.cu
gcc -o zzzz xxxx.o yyyy.o -Os -ltcmalloc -fopenmp -lstdc++ -L/usr/local/cuda-5.5/lib64 -lcudart -lcutil_x86_64 -lgomp -lm

pasoleatis >

I tried the method which had been taught, but it did not go well.

I am sorry reinstalling the driver did not work. Maybe your card has some problems. You could contact the manufacturer and ask for instructions how to test it.

Without access to code one can give only generic suggestions. An accuracy issue does not point to a hardware problem. Make sure to use the most recent driver available for GTX Titan (I believe that would be 325.xx driver).

I would suggest careful checking the return status of all CUDA API calls and kernel launches. Also, run the app with cuda-memcheck and valgrind (or similar tool) to detect out of bounds accesses and uninitialized data. Beyond that, use the debugger and / or printf() to debug the code.

pasoleatis,njuffa>

Thank you!

pasoleatis>

Don’t mind, please.

I have 3 GTX-Titan and 3 GTX-580.
My program uses graphic card of 1-3 units.
It works well in three even one with the GTX-580.
But,it doesn’t work well in even 1,2,3 with GTX-Titan.
So, I think that it is not a problem of each card .

njuffa>

I have already tried the latest driver.
But, It didn’t solve my problem.
I think that if it is the problem of the program, the same problem to occur even GTX-580.

Hello,

Whenever I use a FFT library I apply 3 tests to be sure I uses it correctly.

test 1) forward transform followed by a bacward transform should give the same arry multiply by the number of points.
test 2) put a periodic function such as 2cos(idx*q) and make a forward transform. This will result a matrix with only 2 non-zero elements which are situated at q and -q. Keep in mind that the elements 1:lx/2 correspond to positive wavevectors , while the second half correspond o negative wavevectors.

test 3) Perform a convolution you can do analytically. I usually do the laplacian (f(i+1)+f(i-1)-2f(i)) on a matrix with all elemnts zero expect one which has value 1. In k space the corresponding kernel is 2(cos(kx)-1)). For a matrix with 0 1 0 , after the convolution in k space it will return 1 -2 1.

Good luck.

pasoleatis>

Thank you!

I think you are saying “should be compared with those known”.
I made a comparison with the analytical solution and the result of my program.
The result of the GTX-580 was within the expected calculation accuracy ,
but the result of GTX-TITAN was worse about two-digit .
I think there is some issue due to hardware.
But, I do not know more than that…

Hello,

I understand now. You have a program which runs on GTX 580, but it gives different resutls on Titan. I suggest to write some small tests programs to see which fucntion in your program is responsible for the error. If the cufft is the problem, then you can fix it by installing the 325.xx driver. It is also possible that your card is broken. You could check also if other different CUDA programs have the same problem. I am having now problems with floor function for example. It gives me 0 for some cases, while it should give me 1.

pasoleatis>

I am grateful for your patient support !

I have tried the driver(325.15), but it did not go well.
As you said, I will make a simple program and check it with GTX-580 and GTX-TITAN .
Due to circumstances, I can not do it immediately .
But, when I get some results, I’ll post here.

Thank you again!

Hello, Last week i bought a new titan Z, I put it in my pc and its not working, it won’t start up. I tried to put it in my other pc and its not working there as well. Can you help my?

Greets, Tijmen Rijs

Not working how? What are the specific symptoms? Is your machine running an OS platform supported by CUDA? Did you follow the Getting Started guide relevant to your platform?

Did you buy this Titan Z as a brand-new item, or did you acquire it used? Any chance the hardware could be defective (e.g. damaged in transport)?

If your machine does not start at all after you added the GPU, your power supply unit (PSU) may be insufficient. Also, check whether you connected the power connectors on the GPU correctly. I think there is one six-pin and one eight-pin connector. There may be a conflict with other hardware in the system regarding PCIe resources, in which case you would want to examine your system BIOS settings.

hi, I tried everything. I connected everything good to my motherboard and its still not working the computer starts but the titan isn’t . In my other computer I have another titan Z and he is working the other titan isn’t Its Wired. I bought it new. Please help my out?!

It is close to impossible to make a remote diagnosis based on almost no information. What specifically are the symptoms of “the Titan isn’t [working]” ? If you swap this new Titan Z with the older Titan Z in your other machine that you state works fine, what happens? Such a swap is a controlled experiment in which only one variable (namely the GPU) changes. So if your new Titan Z does not work after correct installation in that machine (proper insertion into PCIe slot, proper plugging-in of power connectors), it raises the possibility of a hardware defect in the new card.

The Titan Z isn’t just working on the motherboard, The motherboard isn’t defect it is the graphic card ive seen some videos about it and i did it correcly as they did and its still not working… I dont have much experience about computers but a graphic card installing on a motherboard isn’t hard right? all cables from the graphic card are fine connected to the motherboard. I even test the watt voltage on the motherboard with a voltage meter and its fine, so its the graphic card thats damaged…

How about the 2 cables connected to the PSU? What is your PSU watt rating? Model? Brand?

Did you try your non working Titan Z in the computer which works with another Z?

The psu watt rating is 27,9Watts

and i tried to install the titan z in the other computer and its still not working there

If you mean 279 Watts, that’s not enough. The card itself requires 375W, recommended 700W for the computer.

http://www.geforce.com/hardware/desktop-gpus/geforce-gtx-titan-z/specifications

You may have fried it by using a PSU with not enough power.

yes i meaned 279. Ill try to install a new psu to my computer thx,

And is a 500 Watt psu fine for a gtx 750 2gb?