How can I install nsight systems in l4t-pytorch container?


I’d like to install nsight systems into

sudo apt-get install cuda-nsight-systems-11-4 nsight-systems-2022.5.2

The command above doesn’t work. It is guided in an old blog.

I visited a place.

The link for nsight systems download provided above returns 404 page not found error.

How can I install nsight systems into the container -

Thank you!

@tcourtney can you respond to this?

Sorry you encountered the stale URL references. I haven’t been able to read that blog post either so I am missing some context of your request.

Here is the updated link for downloading the latest version of Nsight systems: Getting Started with Nsight Systems | NVIDIA Developer

Maybe these pages will help:

Let me know if these updated pages or if you have more questions.

Hello tcourtney,

It seems the nsight systems 2022.5 is supposed to be downloaded from here.
Could you open the link above?

Then, maybe, I need to find Nsight Developer Tools and find a link saying NVIDIA Nsight Systems.
Could you kindly click this link?

The linked page is saying:

Page Not Found

This page no longer exists. It is a non-supported format.

If you have any questions, please contact us.

I tried for jetapck 5.1.1 and jetpack 5.1. Both are same.
I’d like to find Nsight systems…
Could you check this out?

Hi jhjo,

From the jetpack 5.1.1 page, could you try the link “Jetpack Documentation”? How to Install JetPack :: NVIDIA JetPack Documentation

That page has more details on how to install the packages. Please check those instructions and see if they help. One of the links on that page points to a package repo: Index that includes .deb for Nsight systems.

Please let me know if it works for you.

1 Like

Try sudo apt install nvidia-nsight-sys, it’s a part of nvidia-jetpack and you can see it if you look at the packages that come with nvidia-jetpack-dev by running sudo apt show nvidia-jetpack-dev.

Hello tcourtney,

From the repo: Index you pointed, I found nsightsystems dpkg file. And I tried it and the result is success!
Thank you very much!

1 Like

Hi onish-ai,

I tried APT commands but it was not successful.
I found the solution from tcourtney’s answer.
Thank you!

Hello tcourtney,

Could you check this out?

The nsys I installed in the docker container - - doesn’t seemed to work!

Am I missing something? Did I install the right .deb file?
Is the .deb file compatible to my l4t jetson container(

Thank you…

I believe this would be helpful to others who might be interested in this thread.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.