How to disable iommu in Jetson Orin devkit?

Hi Guys,

I got a Jetson Orin devkit, and I pluged a NIC on the PCIe slot intended for an DPDK use case.
Now I find myself not able to set “iommu.passthrough=1” to disable iommu in extlinux.conf which works in my ARM server. If I do so, the Orin devkit will not work after rebooting, with the fan stopped and no GUI output.
I also tried to flash it, with selecting “smmu default passthrough” or deselect “smmu support” in “make menuconfig”, same result.

So I wander if there is a way to disable iommu?
Thanks alot!

I alse tried to remove the following lines off in file tegra234-soc-pcie.dtsi

iommus = <&smmu TEGRA_SID_PCIE3>;
dma-coherent;

I removed it for C1,C4,C5,but after I run my dpdk use case, dmesg says:

arm-smmu 12000000.iommu: Unhandled context fault: fsr=0x80000402, iova=0x7fffffffc0, fsynr=0xc0011, cbfrsynra=0x1014, cb=6
Disabling IRQ #14
mc-err: unknown mcerr fault, init_status=0x00001040, ch_init_status=0x00000200, hubc_init_status=…
ign_uio 0005:01:00.0 uio device registered with irq 3000
nvidia_smmu_context_fault_bank: 1808 callbacks supressed

So I wonder if I can remove the 2 lines for C0~C9…

@kayccc