I run into this error while installing pytorch : libmpi_cxx.so.20: cannot open shared object file: No such file or directory

i am using Jetpack 5.1 (L4T 35.2.1) and i am trying to install pytorch v1.14.0 and torchvision v0.14.1 and while following the steps found on PyTorch for Jetson when i have to run python3 setup.py install --user i get this error : libmpi_cxx.so.20: cannot open shared object file: No such file or directory
any advices?
btw i have just flashed the jetson


Please check below comment:


hi. thanks for the fast replay
i saw that link myself but i can’t acces it i don’t know why

and i remember i ran those commands before installing
shoud i uninstall it and reinstall it ?

guys i solved it, i made a mistake:
i didn’t change the url in wget -O <file_name>
thanks for help anyway
btw how do i get that url, i found an example on Deploy YOLOv8 with TensorRT and DeepStream SDK | Seeed Studio Wiki , but i still don’t know how to get the url


Do you mean the below command?
For example, JetPack 5.1/Pytorch 1.14:

$ wget https://developer.download.nvidia.com/compute/redist/jp/v51/pytorch/torch-1.14.0a0+44dac51c.nv23.02-cp38-cp38-linux_aarch64.whl

If yes, the URL link can be found on the topic of the comment (right-click ->copy URL).

1 Like


I have similar problem. I’m using Jetpack 5.1.2-b104 and I’m trying to install pytorch v1.6.0 from .whl file in virtual environment with python 3.6.8. Installation goes well. When I list libraries using pip list I see torch 1.6.0 However when I try to import torch in python terminal script I see error mentioned above. I used sudo apt-get install libopenblas-base libopenmpi-dev. I prefer not to use docker

@tomasz.niedzialkowski there is not a PyTorch 1.6.0 wheel that we’ve built for JetPack 5.1.2 and Ubuntu 20.04, so my guess is that you’ve installed one of the wheels that was built against JetPack 4 and Ubuntu 18.04. 18.04 and 20.04 ship with different dependency versions (like the libmpi version is different). Instead, install one of the PyTorch wheels built for JetPack 5.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.