Import cv2 complains not found

As what I see here, Pkgld not provided for tegra libraries (including `nvidia-l4t-multimedia-utils`) - #3 by DaneLLL , this lib is no more compiled for jetpack 5, but why python complains about this? What should I do, tried reflash image and setup all the package needed for my facial detection script again, still have this problem. Is there some conflict within the system or I should rebuild opencv and opencv-python?
My system:
Jetpack 5.1.2-b104
R35 (release), REVISION: 4.1, GCID: 33958178, BOARD: t186ref, EABI: aarch64

Do you use OpenCV package installed through SDKManager? We have deprecated the prebuilt lib on Jetpack 5 and it’s supposed to work if your environment is the default one(installed the whole setup through SDKManager)

Hi, yes, I installed opencv from SDK manager, can confirm that compiling c++ with no problem ,but import cv2 don’t work.
I tried to build a local version of opencv again over night, now import cv2 works, maybe something went wrong in the flashing process?

Do you use Orin Nano developer kit and flash system image through SDKManager? Each release is validated in SQA tests and it is unexpected to observe this error.

Yes, the developer kit with the official SDK manager. Through some trail and error, it seems to be some conflict with conda, as my code requires multiple python versions, but I find once I installed conda in a newly flashed system, the OpenCV just went wrong. But can confirm that rebuilding from source for OpenCV solves the problem, I will just call it a day and leave it there.

We try to run the sample on clean flashed Orin Nano developer kit but don’t hit the error:
Doesn't work nvv4l2decoder for decoding RTSP in gstreamer + opencv - #3 by DaneLLL

Probably it happens in certain condition. Since you have worked out a solution, it should be good now. For further query, please create new topics.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.