INT8 calibration error

An error happened when running the calibration datas:
tensorflow/contrib/tensorrt/kernels/] Check failed: t.TotalBytes() == device_tensor->TotalBytes() (2220 vs. 2192)
Aborted (core dumped)

what causes this problem? running with the FP32 inference graph is OK.

If you open a TensorRT issue, here is our policy.

TensorRT developers respond to issues. We want to focus on fixing bugs and adding features.

Provide details on the platforms you are using:
Linux distro and version
GPU type
nvidia driver version
CUDA version
CUDNN version
Python version [if using python]
Tensorflow version
TensorRT version
If Jetson, OS, hw versions

Describe the problem


Include any logs, source, models (uff, pd) that would be helpful to diagnose the problem.

If relevant, please include the full traceback.

Try to provide a minimal reproducible test case.


I ran into the same error, although while doing a different thing.

Linux distro and version: Ubuntu 16.04
GPU type: GTX 1070 with Max-Q
nvidia driver version: 418.56
CUDA version: 10.1
CUDNN version:
Python version: 3.52
Tensorflow version: 1.13.1
TensorRT version:

This occurs when within the same code, I convert more than one graph using trt.create_inference_graph(), followed by tf.import_graph_def(trt_graph), and then running an input through the first graph, then the second graph.