Is it OK to dev with: (nvcc -V = 11.7) & nvidia-smi(CUDA Version: 12.0)?

is it OK to dev with: (nvcc -V = 11.7) & nvidia-smi(CUDA Version: 12.0)?
it’s compatible as long as the nvidia-smi(CUDA Version: ) is Greater/Equal than the (nvcc -V )?
thanks!

Yes, as long as the CUDA version reported by nvidia-smi is greater than or equal to the CUDA version reported by nvcc -V then you should have a “compatible” setup. Code properly compiled with that nvcc should run in that environment. this question/answer has a longer discussion/explanation.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.