ISAAC SIM Remote Streaming Web or Ubuntu 20.04

Is there a way to run the streaming service from Ubuntu 20.04 or some web interface? I know WebSight was discussed at GTC, and I was wondering if that is available yet.

If not, is it worthwhile for me to try to run the streaming out of an ubuntu 18.04 container?

Thanks in advance for your advice.

Hi, currently Isaac Sim currently only supports Ubuntu 18.04 (native and containers) but you should be able to run the Kit Remote streaming client on Ubuntu 20.04 or Windows too.

WebSight is a visualization tool for Isaac SDK but not Isaac Sim. Both Kit Remote client and WebSight can be run on the same machine but they serve a different purpose.

For 20.04, I am having trouble installing the codecs

sudo apt-get install libavcodec57 libavformat57 libavutil55

As provided in instructions here.

Am I missing something?

I am getting the following

Package libavcodec57 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Sorry I have not tested it on Ubuntu 20.04. I believe that lib is replaced by libavcodec-extra. Does the other libs install successfully?

No, all three libraries are not found.

I have the newer versions of these libraries, but when trying to edit the launch script to point to the newer versions, I ran into issues.

Thanks for trying. I’ll take a look and file an issue for this. Meantime, I would recommend running it natively on Ubuntu 18.04 or Windows machine.

I was able to get it to run on 20.04 by installing the old libs from the bionic source. (Its obviously a bit of a hack)

I added the bionic sources:
deb bionic-security main universe
deb bionic main universe

And then installed the old deps as per the instructions.

This at least makes it so I can run the kit remote, however I can’t fully test it as I ran into issues connecting to an AWS instance so take this with a grain of salt.


Thanks, this worked and helped me get it working on 20.04. I am getting different, I think netowrking related, issues now, but at least the client runs!