Jetpack 4.4: Created image with jetson-disk-image-creator.sh will not boot past nvidia logo

Hi, I’ve been using create-jetson-nano-sd-card-image.sh in previous Jetpack to create smaller backups of my OS, which work fine - as in I can flash my created .img files with etcher and they boot fine on my nano.

Now I’ve rebased with Jetpack 4.4 and moved to jetson-disk-image-creator.sh, but using the same process, flashing the resulting .img and booting just gives me the nvidia boot screen and nothing else after that.

How can I debug this to see what is going wrong?

My process for creating the image is:

It creates the image fine with no errors, but doesn’t boot past the nvidia logo. Any ideas?

When it didn’t boot past the logo, it means it stuck somewhere in the bootloader.
For such case, please dump the serial console log from uart.

Solution from @fnoop is great, but I ran into a similar problem with Jetson Nano B01 which is not supported by the version of Tegra linked above. I have not been able to find a newer version Linux_for_Tegra even though Nvidia documentation claims you can find it in the latest Jetpack 4.4. Here’s what I ended up doing that worked like a charm:

  1. Etched and booted from baseline jetpack 4.4 image (called sd-blob-b01.img once unzipped)
  2. Installed and setup everything the way I wanted it
  3. Opened the memory card on another linux system and mounted partition one on /fs1
  4. Used truncate +s 15GB sd-blob-b01.img to increase the total size of the “disk”
  5. Used gparted to delete the partition and then create a new partition with the name APP
  6. Mounted as a loopback device with losetup --partscan /dev/loopX sd-blob-b01.img
  7. Formatted the partition with ext4 via mkfs.ext4 /dev/loopX
  8. Mounted that partition on a separate mount point via mount /dev/loopX /fs2
  9. Rsynced via rsync -avz /fs1/* /fs2/
  10. Unmounted everything and etched my new image (sized to ~24GBs)
  11. Booted off the new SD card and test!

Hope this helps someone. @nvidia please let us know if a newer version of Linux_for_Tegra is available as a standalone download somewhere.

Hi James,

Any “driver package” link on the dlc website points to a Linux_for_Tegra tarball.