JetPack 4.5 - Xavier - IMX390 cameras (4 cameras not functioning simultaneously)


We ported our custom BSP for Xavier module + IMX390 cameras from 32.4.4 to latest L4T 32.5.

I notice a weird behaviour when I try to stream 4 cameras at a time.

When video streaming starts on the second camera it terminates the first one and so on. At the end there is only one camera streaming video.

So I am able to stream video from just one camera at a time. Whereas on L4T 32.4.4 all 4 cameras were able to stream simultaneously.

I also copied over imx390.c, max9295.c and max9296.c files from 32.4.4 onto 32.5, even then cameras were unable to stream simultaneously on 32.5 L4T.

I have attached the dmesg log file and the command txt file for your reference.

I use the following command to test:

gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! “video/x-raw(memory:NVMM), height=480, width=640, framerate=30/1” ! nvvidconv ! ximagesink &

Can you please let me know if anything updated on L4t 32.5 is causing this issue.


dmesg_imx390_4cam.txt (82.0 KB) (1.4 KB)

Enable the argus log to check.

sudo su
kill the process of nvargus-daemon
export enableCamPclLogs=5
export enableCamScfLogs=5
export enableCamCaptureLogs=5

lanuch camera APP from another console

Hello ShanceCCC,

I have attached the argus log output from the terminal.

I ran (1.4 KB) script in one terminal with the above provide commands in the other.

Ran 4 cameras each one started after 5 sec. As soon as second camera starts streaming first one closes.

Please find attached log file.

nvarus-log.txt (2.1 MB)


Could you check the context of the tegra_camera_platform{} also can you run the argus_camera for multiple session?


I am unable to run multiple sessions of argus_camera at the same time.

I have the nvargus log file attached here nvargus-session1.txt (1.4 MB).

I also have the output of tegra_camera_platform{} from a live Xavier module attached here.tegra-camera-platform.txt (3.4 KB)

Please let me know if you need any more details.


Did you check the devname in the tegra-camera-platform{}?


Yes I check the devname in tegra-camera-platform{}.

I did not chnage anything in device tree while porting from L4T 32.4.4 to 32.5.

This DT is verified on L4T 32.4.4, but does not work with L4T 32.5.


Hello ShaneCCC

Is there any update on this. Still struggling to get multiple cameras to stream at a time.


Have a try this lib for r32.5.x

Hello ShaneCCC,

This didnot allow streaming of multiple cameras at once.


Please try below command before launch camera:

sudo service nvargus-daemon stop
sudo enableCamInfiniteTimeout=1 nvargus-daemon

Hello ShaneCCC

I replaced file in /usr/lib/aarch64-linux-gnu/gstreamer-1.0/ as per your suggestion.

After that I ran the follwoing commands:

sudo service nvargus-daemon stop
sudo enableCamInfiniteTimeout=1 nvargus-daemon

I have attached the output from the commands: output.txt (12.1 KB)

This didn’t fix the issue just enabled better logging.

Yet unable to stream multiple IMX390 cameras at a time.


Could you narrow down to 3 or 2 sensors to check?

Hello ShaneCCC,

I already did that. I am testing with just 2 sensors now, but they are also unable to stream simultaneously.

Please let me know if you need any more information.


There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Are you able capture by v4l2-ctl simultaneously?

Hi, I had a same problem with 4 imx390 cameras on Xavier(JP 4.4). These commands helps me:
sudo service nvargus-daemon stop
sudo jetson_clocks
sudo enableCamInfiniteTimeout=1 nvargus-daemon &

1 Like