Jetpack 5.1 pva oversubscribe error


I had a problem similar to this.

when I run more than 2 processes at the same time with vpiImageCreate function, I got an error:

erminate called after throwing an instance of ‘std::runtime_error’
what(): VPI_ERROR_INVALID_OPERATION: PVA is not available and may be oversubscribed in the system: PvaError_DeviceUnavailable
Aborted (core dumped)

but I never used any PVA backends, I try using VPI_BACKEND_CUDA or VPI_BACKEND_CPU or VPI_BACKEND_VIC, no matter which one I use, it got the same error:“VPI_ERROR_INVALID_OPERATION: PVA is not available and may be oversubscribed in the system: PvaError_DeviceUnavailable“

My environment as follows:

machine: aarch64 ubuntu20.04
module: NVIDIA Jetson Xavier NX (16GB ram)
Jetpack: 5.1

Is there any way to solve this problem?


This is a known issue since there is a process limit in PVA.
(VPI by default subscribes the PVA backend when initialization).

We have fixed this issue in our internal branch.
You will get the fix in our next public release.



But please give our latest software a try.
In JetPack 5.1.1, this error occurs when the 3rd VPI library is launched.


OK. Thank you for your reply!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.