Jetson jetpack 6.0 on Orin nano dev . kit - GPIO no OUTPUT , No LED blink etc

The GPIO are reading input out but when a LED is attached, No response to the PINS. Please help. I have used Jetson.GPIO as GPIO . Also tried with RPi.GPIO as GPIO , but no response.

Hi hemsinghb,

Are you using the devkit or custom board for Orin Nano?
Is the issue specific to JP6.0-DP or it also not work with JP5.1.3(L4T R35.5.0)?

Which GPIO are you trying to control?
Have you configured the pinmux before use?

Hi, Im using Dev kit . the issue is with JP 6.0 only. GPIO 12 , I tried. how to do pinmux ?

I have a similar problem here. I tried to use this python lib GitHub - NVIDIA/jetson-gpio: A Python library that enables the use of Jetson's GPIOs and followed the instructions. I found that the rules file is located somewhere else but that doesnt matter. I used the sample script but non of the GPIO showed any signal. So i looked around to find that both gpio devices in /dev/ are present and used the linux command line tools to change the GPIO states (those tools Manage the GPIO lines from command line with gpiod). The LINE ids referring to the GPIOs on the dev kit board are referenced in the gpio_pin_data.py file in the jetson_gpio python lib. I where able to change pin functionalities as far as the gpioinfo command is concerned. Permissions etc. are all correct.
At no time a was able to change anything in the physical world, even though gpioinfo has changed.

Ah, yes, I am also running jetpack 6.0 on a Jetson Orin Nano with DevKit, that might be useful information.

I also was unable to use RPi.GPIO or Jetson.GPIO to control the GPIO pins successfully on Jetpack6 with an Orin Nano. I re-flashed with Jetpack 5.1 and the GPIO pins work as described in Jetson.GPIO documentation.

Unfortunately I am having many troubles getting the rest of my code (which worked well on Jetpack 6) to run on Jetpack 5 (due to version changes I think) but the GPIO works on Jetpack 5

To controlling the GPIO in JP6, we would suggest configuring the column Pin Direction to Bidirectional so that you can control them through Jetson.GPIO or gpiod.

how to configure column Pin direction to Bidirection, please help.

You need to download pinmuxing spreadsheet for your Jetson module and change the direction inside the spreadsheet and generate dtsi files.

There are steps to followed further after this.pls refer to Nvidia online developer website for documentation

its an issue with only 6.0 DP. Im using Dev Kit. I didn’t use pinmux. I did 40 pin configuration and kept pin ( pwm) . but its not working.

How to do pinmux elaborate please.

Please refer to Jetson Orin NX and Nano Series — Generating the Pinmux dtsi Files

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.