Jetson Nano 2GB DLI docker not working with USB Camera or CSI Camera

Hi,
I have been following the NVIDIA Deep Learning Institute’s Getting Started with AI on Jetson Nano course with my Jetson Nano 2GB until I got to this part where I have to run the line below:

./docker_dli_run.sh

And here is the error I get everytime, whether I use a CSI camera or USB camera:

    docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused "process_linux.go:449: container init caused \"process_linux.go:432: running prestart hook 0 caused \\\"error running hook: exit status 1, stdout: , stderr: exec command: [/usr/bin/nvidia-container-cli --load-kmods configure --ldconfig=@/sbin/ldconfig.real --device=all --compute --compat32 --graphics --utility --video --display --pid=11253 /var/lib/docker/overlay2/6815f9e611e3a721c0db51cf9c841be6894334c4f3472d9113b2fe032926125a/merged]\\\\nnvidia-container-cli: mount error: file creation failed: /var/lib/docker/overlay2/6815f9e611e3a721c0db51cf9c841be6894334c4f3472d9113b2fe032926125a/merged/usr/lib/aarch64-linux-gnu/libnvidia-fatbinaryloader.so.440.18: file exists\\\\n\\\"\"": unknown.

How can Isolve this problem and move to the next thing: Logging into the JupyterLab server?

Hi salau.olamilekan,

Sorry for the late response, is this still an issue to support?

Hi @salau.olamilekan, does your version of JetPack-L4T match the version tag of the dlinano container that you are using?

You can check your L4T version with cat /etc/nv_tegra/release

So for example, if your L4T version is R32.5.0, you would use nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.5.0. Whereas if your L4T version was R32.4.4, you would use nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.4.4

You can find a list of the dli-nano container tags here: https://ngc.nvidia.com/catalog/containers/nvidia:dli:dli-nano-ai/tags

Thanks! The JetPack is 32.5.0. How do I remove/uninstall nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.4.4?

You can run sudo docker rmi nvcr.io/nvidia/dli/dli-nano-ai:v2.0.1-r32.4.4

(although you don’t actually need to do this before running the r32.5.0 version of the container)

Thanks @dusty_nv. I just edited the file and replaced 32.4.2 with 32.5.0 and ran it again.

Hi @dusty_nv. I was able to use a USB Camera as it’s in the DLI course but the CSI camera is still not working with it. From the course, the same path /dev/video* was used to access both cameras but I think the CSI camera can’t be accessed on that path.