Jetson Nano encoding frame rate issues

I’m trying to build a stereoscopic camera using a Jetson Nano dev kit and two CSI cameras.

The example pipelines from the accelerated gstreamer chapter of the docs have worked at 1920x1080 60fps if I use nvoverlaysink, but when I use a filesink example the video files are saved at less than 1fps.

https://docs.nvidia.com/jetson/l4t/index.html

I also tried building and running the examples from
https://docs.nvidia.com/jetson/l4t-multimedia/
and encountered a similar problem.

The most successful attempt was using nvgstcapture which did produce a 1280x720 30fps video, but failed when I tried to increase the resolution to 1920x1080.

Ideally I’d like to sync, composite and encode the left and right eye cameras input in the same file. I’m new to developing on jetson and any advice or further resources is much appreciated.

Hi,
Please check if you can see video preview of the tow sources:

$ gst-launch-1.0 nvarguscamerasrc sensor-id=0 num-buffers=300 ! 'video/x-raw(memory:NVMM),width=1920,height=1080,framerate=60/1' ! nvoverlaysink
$ gst-launch-1.0 nvarguscamerasrc sensor-id=1 num-buffers=300 ! 'video/x-raw(memory:NVMM),width=1920,height=1080,framerate=60/1' ! nvoverlaysink

If the sources are good, please try

$ gst-launch-1.0 nvcompositor name=nvcomp sink_0::xpos=0 sink_0::ypos=0 sink_1::xpos=1920 sink_1::ypos=0 ! nvvidconv ! nvv4l2h264enc ! h264parse ! matroskamux ! filesink location=stereo.mkv nvarguscamerasrc sensor-id=0 num-buffers=300 ! 'video/x-raw(memory:NVMM),width=1920,height=1080,framerate=60/1' ! nvvidconv ! nvcomp.sink_0 nvarguscamerasrc sensor-id=1 num-buffers=300 ! 'video/x-raw(memory:NVMM),width=1920,height=1080,framerate=60/1' ! nvvidconv ! nvcomp.sink_1

When I run the first two I get this error:
ARGUS_ERROR: Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute: 679 Frame Rate specified is greater than supported
GST_ARGUS: Running with following settings:
Camera index = 0
Camera mode = 2
Output Stream W = 1920 H = 1080
seconds to Run = 0
Frame Rate = 29.999999

If I change framerate to 30/1 they run fine. When I make the same change to the compositor pipeline it closes after ~10 seconds and the file it produces is ~1fps.

Hi,
The sensor does not support 1920x1080 60fps. You may try 30fps.

I tried 30 fps and it works fine for the overlaysink pipelines, but the compositor pipeline still fails. The clip it produces is ~.5 fps and the pipeline closes on its own after ~10 seconds without an error

Hi,
It sets num-buffers=300 so the pipeline stops once the source outputs 300 frames. For 30fps, 10 seconds look expected.

You may check the video file through Mediainfo.
https://mediaarea.net/MediaInfo