Jetson Nano HDMI Display No Output

Jetson Nano HDMI Display No Output

I am using Jetson Nano a02 version.

There is no problem while using the Jetson Nano I was developing.
If the sd card that was being developed (the sd card running yolo3 for image recognition) was moved and inserted, the display could not be displayed normally.

I have 3 Jetson Nanos.

First, I installed jetpack 4.6.1 and was testing people counting and tracking based on real-time video using TensorFlow.

In this Jetson Nano, all versions of images worked normally.
(LT 32. 3.1/ 4.3 / 4.4)

If this sd card is moved and inserted into other versions of Jetson Nano, the screen does not appear and it does not boot normally.

It was confirmed that if a new jetpack image of the same version was created and put in the other two Jetson Nanos that did not work, it went all the way to the Jetson Nano’s setup window.

In other Jetpack versions (4.3, 4.4), normal operation was also confirmed.

Nevertheless, it does not work normally in the developed sd card image that was copied.

I would like to know the cause and how to solve it.


Just want to clarify. Is your 3.1/4.3/4.4 indicating 32.3.1/32.4.3/32.4.4? If so, could you correct your term here?

Jetpack version is not equal to L4T version. We do really have jetpack3.1 version which does not support jetson nano. I don’t think you are talking about that. So please correct it to avoid confusion.

You can try to dump the serial console log from error case first. So that we can know what is going on.

Also, I don’t really understand what does this comment try to say.

In this Jetson Nano, all versions of images worked normally.
(Jetpack versions 3.1, 4.3, 4.4)
If this sd card is moved and inserted into other versions of Jetson Nano, the screen does not appear and it does not boot normally.

What version is inserted here to cause error?

It was confirmed by using the ‘head -n 1 /etc/nv_tegra_release’ command in the terminal window.

In addition, as I wrote, the jetpack version that did not boot was also 4.6.1.

I mean you should add “rel-32.x.x” not just telling the version is x.x. Ok?

So this issue is you tried jp4.6.1 on one device. Then insert some old jetpack sdcard to it and it cannot boot?

If so, share the uart log first.

[0000.126] [TegraBoot] (version 00.00.2018.01-l4t-33e7fa82)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.152] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x2c1de1
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.217] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.223] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.260] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.266] Non secure mode, and RB not enabled.
[0000.272] Invalid GPT Partition
[0000.287] Using BFS PT to query partitions
[0000.291] failed to load NvTbootTbootCpu from (2:0)
[0000.296] re-load NvTbootTbootCpu from (4:0)
[0000.426] Csd NumOfBlocks=62333952
[0000.485] Using GPT Primary to query partitions
[0000.679] Using BFS PT to query partitions
[0000.684] Error is 1

It will boot even on old jetpacks.
For the version that booted successfully (the date it appears in the download center)
jetpack 4.3 (19.12.17), 4.4 (20.04.21/20.07.07)
The version is booting.

Also, in version 4.6.1, it was confirmed that the initial boot setting screen to set the language of the Jetson Nano was displayed.

Additionally, if you use the same sd card and connect it to the Jetson Nano, which was originally developed, it boots normally.

Then please flash the qspi on your board with sdkmanager + new jetpack release. This will resolve this issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.