jetson Nano -Issues Comunicating with Stm32 through UART

When Jetson nano’s serial port (j41) is connected to stm32,
how to set the device number when transferring data from nano to stm32. is ‘/dev/ttyTHS2’ or others?

hello 851722604,

please refer to Topic 1050148 for the setups, and please check NVIDIA Jetson Nano J41 Header Pinout for the pinouts.

I tried all the settings “/dev/ttyTHS#”, but still can’t communicate with STM32.
can you tell me directly how to how to do.

hello 851722604,

if you would like to communicating through UART, please check UART parameter settings is 115200n8.

As a general method of testing I suggest the following (not specific to a Nano)…

Install a nice terminal program, e.g., gtkterm. This is what I use. Others use PuTTy or minicom.

Put the port wiring into loopback. For the UART connector in question, wire TX to RX. If flow control is being considered, then also RTS to CTS (this doesn’t hurt even if you don’t use flow control).

At the settings you expect to use that port on launch the console program and see if typing echoes back. If not, then something is wrong. However, you will be guaranteed it isn’t because the settings on the two ports differ…the port is talking to itself (you will find whenever something talks to itself it has a tendency to agree :P).

Example for 115200 8N1 on ttyTHS2:

gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyTHS2

Always test at or below 115200 before trying faster speeds. If you test faster speeds try to always use two stop bits.