Jetson Orin Nano devkit SD flashed with Jetson Linux 35.5.0 minimal/basic flavor does not start eth0/wlan0 interfaces automatically

I am able to log in through the serial over USB (USB-C) alternative using the username/password created using the script l4t_create_default_user.sh.

~$ ifconfig
l4tbr0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.55.1  netmask 255.255.255.0  broadcast 192.168.55.255
        inet6 fe80::b840:d9ff:fe63:15bd  prefixlen 64  scopeid 0x20<link>
        inet6 fe80::1  prefixlen 128  scopeid 0x20<link>
        ether ba:40:d9:63:15:bd  txqueuelen 1000  (Ethernet)
        RX packets 413  bytes 42565 (42.5 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 15  bytes 2378 (2.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 80  bytes 5992 (5.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 80  bytes 5992 (5.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

rndis0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::b840:d9ff:fe63:15bd  prefixlen 64  scopeid 0x20<link>
        ether ba:40:d9:63:15:bd  txqueuelen 1000  (Ethernet)
        RX packets 242  bytes 24163 (24.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 227  bytes 37328 (37.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::b840:d9ff:fe63:15bf  prefixlen 64  scopeid 0x20<link>
        ether ba:40:d9:63:15:bf  txqueuelen 1000  (Ethernet)
        RX packets 234  bytes 24459 (24.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 146  bytes 35648 (35.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

dhclient is also not starting automatically. When I start it manually, eth0 and wlan0 comes up. eth0 succesfully gets an IP through DHCP.

I couldn’t find any of the common network configuration systems used in Ubuntu:

  • /etc/network/interfaces
  • netplan
  • NetworkManager

I’m not sure if I’m missing a step when creating the rootfs or the rootfs downloaded with the SDK scripts are flawed.

Hi,

It is common that those software are not present when using minimal rootfs.

I guess then that when the documentation says:

This file system does not provide the GUI mode, and all manipulations can be completed only by using the SSH or UART console.

It means that SSH connection is to be done through the ethernet over USB connection (192.168.55.1), which is not common and not properly documented in the rootfs section.

I will try to install netplan and see what happens.

Hi,

Please do not overthink about the document. We actually didn’t assume which IP this SSH is based on.

If the IP is gone, then you can use dhclient to get it back. You already knew that and you have confirmed it would work. SSH can work on that IP too.

Minimal or basic flavor doesn’t have network-manager in the package list. You can either add it to a package list for nvubuntu_samplefs.sh or install it via apt.

1 Like

Thanks!
I first tried netplan but didn’t work. Then I tried installing network-manager and that was enough. Not sure why netplan plus systemd-networkd didn’t work.

Is it posible to disable the access through USB for production?