Jetson TK1 - only CPU0 is running

I just install Jetpack-l4T-3.0 on Jetson TK1. When i run tegrastats,only CPU0 is running:
ubuntu@tegra-ubuntu:~ uname -a Linux tegra-ubuntu 3.10.40-ga7da876 #1 SMP PREEMPT Tue Jun 7 21:05:06 PDT 2016 armv7l armv7l armv7l GNU/Linux ubuntu@tegra-ubuntu:~
ubuntu@tegra-ubuntu:~$ ./tegrastats
RAM 359/1892MB (lfb 278x4MB) cpu [0%,off,off,off]@-1 VDE 0 EDP limit 0
RAM 359/1892MB (lfb 278x4MB) cpu [6%,off,off,off]@-1 VDE 0 EDP limit 0
RAM 359/1892MB (lfb 278x4MB) cpu [13%,off,off,off]@-1 VDE 0 EDP limit 0
RAM 359/1892MB (lfb 278x4MB) cpu [19%,off,off,off]@-1 VDE 0 EDP limit 0
RAM 359/1892MB (lfb 278x4MB) cpu [23%,off,off,off]@-1 VDE 0 EDP limit 0

Anybody can tell me why? thanks!

Unless something goes on that requires the CPUs they may be saving power. See:
http://elinux.org/Jetson/Performance

Hi leakeysong,

It’s saving power mode, when I playing video, the 4 CPU are running:
RAM 616/1892MB (lfb 115x4MB) cpu [56%,21%,30%,14%]@2065 EMC 26%@924 AVP 1%@204 VDE 120 GR3D 35%@852 EDP limit 0
RAM 616/1892MB (lfb 115x4MB) cpu [58%,26%,31%,21%]@2065 EMC 26%@924 AVP 1%@204 VDE 120 GR3D 35%@852 EDP limit 0
RAM 617/1892MB (lfb 115x4MB) cpu [58%,22%,18%,25%]@2065 EMC 26%@924 AVP 1%@204 VDE 120 GR3D 27%@852 EDP limit 0
RAM 617/1892MB (lfb 115x4MB) cpu [53%,27%,25%,18%]@2065 EMC 26%@924 AVP 1%@204 VDE 120 GR3D 43%@852 EDP limit 0

You can refer linuxdev provide link, it’s a good information.

If you want to run all cores at full power all, of the time, try something like this script:

======
#! /bin/bash
echo “This has to be run as root.” ; echo

per http://elinux.org/Jetson/Performance

echo 0 > /sys/devices/system/cpu/cpuquiet/tegra_cpuquiet/enable
echo 1 > /sys/devices/system/cpu/cpu0/online
echo 1 > /sys/devices/system/cpu/cpu1/online
echo 1 > /sys/devices/system/cpu/cpu2/online
echo 1 > /sys/devices/system/cpu/cpu3/online
echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo ; echo “Note: ‘invalid argument’ probably means it has already been set.”

echo “Online:”
cat /sys/kernel/cluster/active
cat /sys/devices/system/cpu/online

for i in 0 1 2 3 ;
do
echo ‘Core’: $i
cat /sys/devices/system/cpu/cpu$i/cpufreq/scaling_cur_freq
echo
done

echo ‘Now we turn up the graphics card speed to maximum:’

do that!

echo 852000000 > /sys/kernel/debug/clock/override.gbus/rate
echo 1 > /sys/kernel/debug/clock/override.gbus/state
echo 'Speed is: ’ cat /sys/kernel/debug/clock/gbus/rate

This also turns up graphics card speed, to best high speed.

If you want to turn down all speeds to minimum, try this one. :)

======

#! /bin/bash
echo “This has to be run as root.” ; echo

now we send turn-off to all but cpu0 in the main “G” quad core

echo 0 > /sys/devices/system/cpu/cpuquiet/tegra_cpuquiet/enable
echo 0 > /sys/devices/system/cpu/cpu1/online
echo 0 > /sys/devices/system/cpu/cpu2/online
echo 0 > /sys/devices/system/cpu/cpu3/online

now we signal to activate the low-power LP core.

echo ‘Ignore error messages’ ; echo

now send signal to use only low-power cpu core.

echo LP > /sys/kernel/cluster/active

echo “Online:”
cat /sys/kernel/cluster/active
cat /sys/devices/system/cpu/online

echo ‘Now we turn the graphics card speed to absolute minimum:’

do that!

echo 72000000 > /sys/kernel/debug/clock/override.gbus/rate
echo 1 > /sys/kernel/debug/clock/override.gbus/state
echo 'Speed is: ’ cat /sys/kernel/debug/clock/gbus/rate
echo 'This is the minimum possible GPU clock speed. ’ ; echo

echo “Done.” ; echo

aha, so that’s it.
linuxdev、carolyuu、underdogma、thanks!