Jumbo packets and Recieve Buffer size

Hi there,
I am trying to use an IP camera (Lucid Vision) with the Jetson nano, I am told by Lucid that the nano will support their cameras but I have come across two issues with this:

  • I am unable to enable Jumbo packets (MTU) on the nano, when I have set the MTU size to 9000 the nano will disconnect from the ethernet cable attached and then attempt to reconnect, but fail and then disconnect again etc etc… Is there something I am doing wrong in terms of enabling Jumbo packets, I am using the command “sudo ifconfig eth0 mtu 9000”.

  • Also in order to use these cameras I need to increase the receive buffer size on the network adaptor, normally this is done with “sudo ethtool -G eth0 rx 4096” but instead on the nano I am getting the error message “Cannot get device ring settings: Operation not supported.”

If anyone has any ideas on how to resolve these issues it would be greatly appreciated.


When “operations are not supported” is seen, it means the driver does not provide an interface to configure this. There is no method to configure it.

As for the jumbo frame, do you see any error in dmesg when you configure the jumbo frame size?

Hi there, thanks for getting back to me, as for the jumbo packets I managed to sort that out using a better ethernet cable. With regards to the driver, is it possible to install a new driver or upgrade it, so that this is possible? If so what would you recommend? Much appreciated.

Hi joe.magrath,

The driver is released by Realtek. If they have some new version, it is okay to upgrade it.

Hi @joe.magrath , could you explain further how you solved the jumbo frames problem using a better ethernet cable? I am running into the exact same issue with the Lucid Vision cameras on Jetson Xavier NX. Setting the MTU to 9000 and streaming images from the camera would cause the whole jetson to crash. I am also unable to set the ring receive buffer size to 4096.

Were you able to upgrade the realtek eqos driver, and did that help? I can’t seem to find how to upgrade it. @WayneWWW could you perhaps provide info on how to upgrade it?

If you could assist by providing more details of your solution that’d be great.


If you see jumbo frame issue on Jetson NX, please file a new topic for your own issue.

Jetson Nano does not have eqos, but jetson NX does. Thus, when issue happens on Nano, most kernel drivers are from upstream. The phy driver is from realtek and what jetson provides is only the lower level usb or pcie interface for it. It has less chance that such issue is happened to usb or pcie driver.

If there is a bug from realtek, then I am not able to resolve it. But if this is a possible bug in eqos, then we can help check. Thus, file a new topic on NX forum first.