L4T 35.2.1 nvbootctrl missing commands and validating Fail-over Rootfs Slot Switching mechanism

Hello Nvidia Team,

  1. I was searching for the is-slot-bootable and mark-boot-successful nvbootctrl-commands in the new Jetpack 5.1.0 (r35.2.1), but unfortunately I couldn’t find them. Aren’t they implemented yet or there won’t be support for these two nvbootctrl-commands in the future? If they will be implemented in the future, which Jetpack version should support them?
  2. My second question is when I tried to test the Fail-over Rootfs Slot Switching. I destroyed the second backup rootfs partition (rootfs.B) and tried to boot from it, where it should fail over to the bootable unused rootfs slot, but unfortunately that didn’t happen. The board doesn’t fallback to rootfs.A (which is working normally) it stucks while booting and restarts! Is the Fail-over Rootfs Slot Switching supported for the newest Jetpack 5.1.0 and if yes how can I test it?

Thanks and best Regards,


What does that mean you couldn’t find them?

Hi WayneWWW,

They are not found in the table of nvbootctrl commands in L4T 35.2.1 documentation, and not in the API of nvbootctrl when I enter $nvbootctrl -h. They were found in the API of nvbootctrl until L4T 35.1, but in the new release they are not there anymore.

Regarding the fail-over mechanism of rootfs, It is found now in the documentation here: Fail-Over Rootfs Mechanism, but unfortunately it didn’t work.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

This feature should be enabled in Jetpack 5.1.
Could you help to provide the full serial console log for further check?