L4T C-boot source now available for download

Hi everyone, the C-boot bootloader source code for Jetson AGX Xavier is now posted online here:


Hi dusty_nv,

is it possible to flash cboot without the process of reflashing everything?

I tried :

sudo ./flash.sh -r -k cpu-bootloader jetson-xavier mmcblk0p1

But it doesn’t work for me. Anybody tried?

I assume cboot is in cpu-bootloader partition as in TX2.

The command is fine, mistake was to rename built lk.bin file to cboot.bin per CBoot_Standalone_Readme.txt

lk.bin file must be renamed to cboot_t194.bin

boot failed:

[0004.036] I> Boot-device: eMMC
[0004.039] I> Add boot-sdmmc to plugin-manager/misc-data
[0004.044] I> Add storage-sdmmc to plugin-manager/misc-data
[0004.050] W> Unknown storage device
[0004.053] I> Add serial number as DT property
[0004.058] I> Plugin-manager override starting
[0004.062] I> node /plugin-manager/fragment-p2888@0 matches
[0004.073] I> node /plugin-manager/fragment-e3326@0 matches
[0004.106] E> Failed to find camera-control-input in target node gpio@c2f0000
[0004.111] I> node /plugin-manager/fragement-tegra-wdt-en matches
[0004.113] I> node /plugin-manager/fragement-soft-wdt matches
[0004.116] I> node /plugin-manager/fragment-pcie-c1-rp matches
[0004.118] I> node /plugin-manager/fragment-pcie-p2822-B00 matches
[0004.122] I> node /plugin-manager/fragment-pcie-c5-rp matches
[0004.125] I> node /plugin-manager/fragment-tegra-ufs-lane10 matches
[0004.127] I> node /plugin-manager/pwm-fan-polarity matches
[0004.134] I> node /plugin-manager/ufs-cd matches
[0004.137] I> Disable plugin-manager status in FDT
[0004.138] I> Plugin-manager override finished successfully
[0004.168] -----------------------------------------------
[0004.170] Synchronous Exception: DATA ABORT (FAR: a06850bd)
[0004.173] -----------------------------------------------
[0004.175] PAR_ELX: 0xa0685b00
[0004.177] ESR 0x96000061: ec 0x25, il 0x1, iss 0x61
[0004.179] -----------------------------------------------
[0004.181]  [Stack Trace]
[0004.183] => pc:0xA0640270, sp:0xA0F94360
[0004.185] => pc:0xA0639A0C, sp:0xA0F94590
[0004.187] => pc:0xA0639954, sp:0xA0F94600
[0004.189] => pc:0xA060F1C4, sp:0xA0F94660
[0004.192] => pc:0xA060F224, sp:0xA0F94770
[0004.196] => pc:0xA060F02C, sp:0xA0F947C0
[0004.200] => pc:0xA060E5A0, sp:0xA0F947F0
[0004.204] => pc:0xA060E574, sp:0xA0F94800
[0004.208] -----------------------------------------------
[0004.213] iframe 0xa0f94270:
[0004.216] x0  0x            7830 x1  0x        80080000 x2  0x               0 x3  0x               8
[0004.225] x4  0x               a x5  0x        a06850bd x6  0x              10 x7  0x               1
[0004.234] x8  0x               0 x9  0x               a x10 0x               6 x11 0x               2
[0004.243] x12 0x               1 x13 0x              40 x14 0x               1 x15 0x             2c0
[0004.252] x16 0x            1500 x17 0x             240 x18 0x               0 x19 0x        a0f94770
[0004.261] x20 0x             7f5 x21 0x        a0658cb4 x22 0x              20 x23 0x        ffffffd0
[0004.270] x24 0x        a06850bd x25 0x             7d2 x26 0x        a064d635 x27 0x        a0f94770
[0004.279] x28 0x        a064d634 x29 0x        a0f94590 lr  0x        a0639a10 sp  0x        a0f94360
[0004.289] elr 0x        a0640270
[0004.292] spsr 0x        600003c9
[0004.295] -----------------------------------------------
[0004.300] panic (caller 0xa0601238): die
[0004.304] HALT: spinning forever...

I am just wondering if there are any successes getting boot from nvme with it.


We have re-uploaded with a corrected CBoot_Standalone_Readme.txt.
Please re-download the package (https://developer.nvidia.com/embedded/dlc/cboot-source-r311) and then try again.