Linux VDA - How to enable H.264 Encode?


As title really.

I have a Linux VM with 7.13 VDA installed. Does anyone know how to enable H.264 Encode?

I’ll caveat this by stating I’m not a Linux guy, so have more than likely misunderstood something …

I have an M60 8Q profile assigned so CUDA is available. GRID 4.1 drivers are installed and it’s licensed.

I’m following this guide:

However, when I try and run this on the VDA:

sudo ctxreg create -k "HKLM\System\CurrentControlSet\Control\Citrix\Thinwire" -t "REG_DWORD" -v "AdvertiseH264" -d "0x00000001" --force

I get this in response:

sudo: ctxreg: command not found

My initial thoughts were, I’m trying to install a Windows registry key on a Linux VM, of course it won’t work. However, as a non-Linux guy, I actually don’t know.

Instructions as usual aren’t as clear as they should be. So any guidance is appreciated

Many thanks

Had a little help from a friend …

For anyone else playing with Linux, you need to run the command from here: /opt/Citrix/VDA/bin

Then as per the link above, run this:

ctxreg create -k "HKLM\System\CurrentControlSet\Control\Citrix\Thinwire" -t "REG_DWORD" -v "AdvertiseH264" -d "0x00000001" --force

then this:

ctxreg create -k "HKLM\System\CurrentControlSet\Control\Citrix\Thinwire" -t "REG_DWORD" -v "HardwareEncoding" -d "0x00000001" --force

to enable it, and then this to check it:

./ctxreg dump | grep HardwareEncoding

All working now.